Re: glib-mkenums in glib 2

On 26 Dec 2012, at 19:20, John Ralls wrote:

> ARGV should be a hint: It means the same thing in perl as it does in C. It seems that glib-mkenums either isn't getting an @ARGV or it's somehow getting cleared before that line.

Thanks John.  I think the fact that ARGV[0] is involved might be significant.  From my hazy recollection, argv[0] is normally the path to the app that got launched (in this case, the path to perl.exe).  There's nothing particularly unusual about that path:-

E:\Program Files\Perl\bin\perl.exe

although it does contain a space.  I wonder if that's the issue??

> It's certainly not a perl version problem.
> Try running the command from a cmd shell and see if you get the same error. If it works from the shell, then there's something about the way MSVS is launching perl that's causing the problem.

I'm ahead of you there!  I've already tried it from a command prompt but the result is the same....  :-(


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]