Re: glib-mkenums in glib 2

On 27 Dec 2012, at 10:05, <Kevin Arpe ubs com> wrote:

I just tried on my Windows machine in a regular "cmd.exe" (command
window).  You need to change the double quotes.  Windows be damned!

I always forget to translate single quote to double quote.  Windows
cmd.exe gives some very strange error messages otherwise.

C:\>perl -e "print(join("""\n""", @ARGV));" foo bar

Then I see:

Interesting...  your variation works if I use my MSYS copy of Perl (which is apparently at version 5.8) but neither variation will work with Perl v5.12.

Knowing that I'd at least managed to get _something_ working, I then tried running 'glib-mkenums' again - this time using Perl from MinGW/MSYS.  However, that essentially gave me the same error that I reported in the first place:-

/* Generated data (by glib-mkenums) */

Use of uninitialized value in substitution (s///) at /usr/lib/perl5/5.8.8/File/ line 338.
fileparse(): need a valid pathname at glib-mkenums line 259

I suppose I could try installing Strawberry Perl but wherever the fault lies, it's looking as if glib-mkenums can't be made to work successfully on Windows (at least, probably not without installing Cygwin).

Has anyone managed to run that script successfully for a plain MSVC (or MinGW) build?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]