Re: impending gdbus merge

On Thu, 06 May 2010 at 16:36:45 -0400, David Zeuthen wrote:
> Btw, for what it's worth, the way the symbol/struct names are set up
> right now is like this: GDBus*/g_dbus_* refers to routines that don't
> care whether the connection is to a message bus, while GBus*/g_bus_*
> refers to routines where the connection is known to be to a message bus.

So: GDBus is like dbus-python's dbus.connection.Connection, which could be
peer-to-peer or to a dbus-daemon; whereas GBus is like dbus-python's
dbus.bus.BusConnection, which is known to be to a dbus-daemon?

That seems a subtle distinction to convey with an added "D"; libdbus uses
dbus_connection_foo vs. dbus_bus_foo, which is where dbus-python's naming
comes from.

I agree that g_dbus_connection_foo vs. g_dbus_bus_foo seems long and
unwieldy, though.

Perhaps it would be sufficient to drop the naming convention, have one
shared namespace, and just have a standard piece of boilerplate to document
the few bus-specific functions, like "this method is only useful on a
connection to a bus daemon"?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]