Re: impending gdbus merge


On Thu, 2010-05-06 at 22:11 +0200, Torsten Schoenfeld wrote:
> As far as I can see from the headers, there seem to be two new 
> namespaces: GDBus/g_dbus_ and GBus/g_bus_.  Judging from 
> <>, GDBus seems to 
> be the low-level API, while GBus is convenience API.  But it seems that 
> GBus is still DBus-specific, so why not call it GDBus, as well?

The namespace for libgio is G like the rest of the code in the GLib
tarball. Why do you think we should call the function g_bus_own_name()
for g_dbus_own_name() or g_dbus_bus_own_name()?

FWIW, we don't call it GIOFile or g_io_file_new() for good reasons (see
the archives when libgio was merged for discussion).


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]