Re: setting up a gtk dev environment

Patrick Hallinan wrote:
On Mon, 2008-07-28 at 10:06 -0400, Owen Taylor wrote:
On Sun, 2008-07-27 at 14:40 -0400, Patrick Hallinan wrote:
On Sun, 2008-07-27 at 14:24 -0400, Paul Davis wrote:
On Sun, 2008-07-27 at 14:08 -0400, Patrick Hallinan wrote:

I wish to help with the development of gtk+ but I'm not having any fun
trying to setup a build environment for gtk+.  I've looked for help at and I have tried using
jhbuild from No dice.
"no dice" doesn't really add up to a bug report on jhbuild. hundreds,
perhaps thousands, of people use that as a way to build and maintain the
GTK stack from svn. what was your problem with it?

I guess you are saying that I should be using jhbuild to get a gtk+
build environment?

I'm using the subversion trunk for jhbuild which I didn't assume was
stable. I get the output below when I try "jhbuild bootstrap"
In general, I'd strongly recommend against jhbuild bootstrap. It:

 - May install older versions of components than your system versions,
   causing weird problems
 - Increases the total amount of things you are building, giving
   more possibilities for failure.

It is definitely a bad idea for Fedora 9, which has nice shiny new
versions of everything. So blow away your install directory and
start over without the bootstrap, and you'll be happier.

Has information about what packages you need to install for Fedora.

I had ignored the FedoraCore link on the jhbuild page because it
indicated FedoraCore and not Fedora.  I thought that it was old.

I installed the missing dependencies and jhbuild sanitycheck gives this:

    [patrick localhost fontconfig-2.6.0]$ jhbuild sanitycheck
    automake-1.8 not found
    automake-1.9 not found

Just install them!

I ignored that and tried "jhbuild gtk+' but the first package
(fontconfig-2.6.0) failed to build.  I think that this is the first

    In file included from ../fontconfig/fcfreetype.h:27,
                 from fcftint.h:26,
                 from fcfreetype.c:48:
/usr/include/ft2build.h:56:38: error: freetype/config/ftheader.h: No such file or directory

Fedora 9 has fontconfig-2.5.0-2.  I guess I will file a bug against
jhbuild if I can figure out how to.

You also need to install the freetype headers which are found in the freetype development package on fedora.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]