Segfault on "save as"

Running Kubuntu Maverick Meerkat, suddenly started getting a segfault
on "Save As" - the dialog box comes up, but none of the file type
options are available, the "Filter" field shows "All Supported Files"
but when I check the dropdown, all the file types show "Unknown".
From there, any action (save, cancel, [X]) causes a segfault:


phil eeep:~$ gnumeric

(gnumeric:14240): Gdk-CRITICAL **: IA__gdk_window_get_window_type: assertion `GDK_IS_WINDOW (window)' failed

(gnumeric:14240): Gdk-CRITICAL **: IA__gdk_window_get_user_data: assertion `GDK_IS_WINDOW (window)' failed

(gnumeric:14240): Gtk-CRITICAL **: IA__gtk_style_detach: assertion `style->attach_count > 0' failed

(gnumeric:14240): Gtk-CRITICAL **: IA__gtk_style_attach: assertion `window != NULL' failed

(gnumeric:14240): Gtk-CRITICAL **: _gtk_style_peek_property_value: assertion `GTK_IS_STYLE (style)' failed
Segmentation fault


I use Gnumeric about once a week, not sure if this was triggered by
a Maverick Meerkat upgrade or if I've managed to hose some file
somewhere since the upgrade.

I tried an uninstall with --purge and a reinstall, and even rebooted
my system (gasp!).  I then got the .debs to install Natty's 
version (gnumeric_1.10.13-1ubuntu1_i386.deb, 
libgoffice-0.8.8-common_0.8.12-1_all.deb, and so on.)  This latest
version seems to be working fine otherwise, but still fails on 
save as.  I tried removing .gconf/apps/gnumeric, no change.

Suggestions on my next steps to help further diagnose the problem?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]