Go to the dot files and look for gnumeric,
if a dot gnumeric exists then rename it as 'gnumeric-old' and retry
after a fresh start.
This has worked in other instances for me an others.
Eric B

On Tue, Apr 26, 2011 at 8:00 AM,  <gnumeric-list-request gnome org> wrote:
Send gnumeric-list mailing list submissions to
       gnumeric-list gnome org

To subscribe or unsubscribe via the World Wide Web, visit
or, via email, send a message with subject or body 'help' to
       gnumeric-list-request gnome org

You can reach the person managing the list at
       gnumeric-list-owner gnome org

When replying, please edit your Subject line so it is more specific
than "Re: Contents of gnumeric-list digest..."

Today's Topics:

  1. Segfault on "save as" (Phil Salkie)


Message: 1
Date: Mon, 25 Apr 2011 18:35:01 -0400
From: Phil Salkie <phil asylumhouse org>
To: gnumeric-list gnome org
Subject: Segfault on "save as"
Message-ID: <20110425223500 GA8095 asylumhouse org>
Content-Type: text/plain; charset=us-ascii

Running Kubuntu Maverick Meerkat, suddenly started getting a segfault
on "Save As" - the dialog box comes up, but none of the file type
options are available, the "Filter" field shows "All Supported Files"
but when I check the dropdown, all the file types show "Unknown".
From there, any action (save, cancel, [X]) causes a segfault:


phil eeep:~$ gnumeric

(gnumeric:14240): Gdk-CRITICAL **: IA__gdk_window_get_window_type: assertion `GDK_IS_WINDOW (window)' failed

(gnumeric:14240): Gdk-CRITICAL **: IA__gdk_window_get_user_data: assertion `GDK_IS_WINDOW (window)' failed

(gnumeric:14240): Gtk-CRITICAL **: IA__gtk_style_detach: assertion `style->attach_count > 0' failed

(gnumeric:14240): Gtk-CRITICAL **: IA__gtk_style_attach: assertion `window != NULL' failed

(gnumeric:14240): Gtk-CRITICAL **: _gtk_style_peek_property_value: assertion `GTK_IS_STYLE (style)' failed
Segmentation fault


I use Gnumeric about once a week, not sure if this was triggered by
a Maverick Meerkat upgrade or if I've managed to hose some file
somewhere since the upgrade.

I tried an uninstall with --purge and a reinstall, and even rebooted
my system (gasp!).  I then got the .debs to install Natty's
version (gnumeric_1.10.13-1ubuntu1_i386.deb,
libgoffice-0.8.8-common_0.8.12-1_all.deb, and so on.)  This latest
version seems to be working fine otherwise, but still fails on
save as.  I tried removing .gconf/apps/gnumeric, no change.

Suggestions on my next steps to help further diagnose the problem?



gnumeric-list mailing list
gnumeric-list gnome org

End of gnumeric-list Digest, Vol 84, Issue 11


"To live is the rarest thing in the world. Most people exist, that is
all." - Oscar Wilde

K-eep L-ocktite R-eady and stay in the D-irt R-iding Z-one

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]