Re: libgsf and bzip2

I "solved" this issue last week, so I thought I'd close it off with a short explanation.

By "solved", I mean I got it working well enough to suit me for now.

The issue appears to be that the libgsf-1 that comes with MinGW (or MSYS or MSYS DTK, whichever it's in) is built against a different bzip2 to that which comes in those packages.

In any case, I rebuilt libgsf-1 without bzip2 support and libwpd and its tools build OK now. Translation: I finally figured out all the dependencies to rebuilt libgsf-1 and it built itself without bzip2 support without me doing anything, because it couldn't find the bzip2 support it needs. One day I'll figure out why, but for now it doesn't matter.

And if I'd found Ryan's page at before I started this, things might have gone much more smoothly!

Thanks for the help


At 06:48 am 13/02/2007, David Hislop wrote:
At 02:25 am 13/02/2007, Ryan Pavlik wrote:
Jean Bréfort wrote:
Le lundi 12 février 2007 à 22:17 +1100, David Hislop a écrit :
I'm building a library and tools (libwpd) on MinGW that uses, among other things, libgsf.

It seems that libgsf has an undocumented dependency on bzip2.dll (or one I can't see :-) ). The versions I'm using are libgsf 1.14.3 and bzip2 1.0.3. I downloaded libgsf binaries and dev from Gnome, and bzip2 binaries and dev from GnuWin32 on SourceForge.

It is not more undocumented than other deps. configure checks if bzip2
is there. I have no idea about how the dll was built.

Everything builds, but executing one (well, any) of the tools fails with entry point BZ2_bzCompress 8 not found in the DLL bzip2.dll.

and the symbol really does not exist in bzip2.dll? Is there any
BZ2_bzCompress* in it?

Yes, the symbol BZ2_bzCompress is in bzip2.dll

The libgfs package config file doesn't mention a dependency on bzip2.

It can't, there is no bzip2.pc file.

I would expect the dependency to be in libgsf-1.pc (or whatever libgsf's pkgconfig file is - I don't have it in front of me right now)

I've tested bzip2 with a prog that calls BZ2_bzlibVersion(), compiled as
   gcc bztestmain.c -o bztestmain -lbz2
and it works fine.

Any hints or info to correct anything dumb I've done would be appreciated.


gnumeric-list mailing list
gnumeric-list gnome org

Fairly certain I've seen something like this before.  I must ask - do you need to build libwpd from source?  There are good binary distributions of it.  Make sure you're using the latest libgsf from TML, and then bzip2 comes from the gnuwin32 project, and you may have to use one version older than most recent if I remember correctly.  Good luck!

No, possibly I don't need to build from source. It won't matter: the problem is that the libgsf used by libwpd, binary or built from source, has this problem with bzip2.

TML no longer has libgsf on his page - links to Gnome.

Which of bzip2 and libgsf do you think needs to be older? Or both?


Ryan Pavlik
AbiWord Win32 Platform Maintainer, Art Lead:
AbiWord Community Outreach Project:

"Optimism is the father that leads to achievement."
-- Helen Keller

"The folder structure in a modern Linux distribution such as Ubuntu
was largely inspired by the original UNIX foundations that were
created by men with large beards and sensible jumpers."
-- Jono Bacon, The Ubuntu Guide


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]