Re: Libgsf 1.10 !!!!!!!


Email is not the web; please do not use HTML in email.

On Mon, Nov 29, 2004 at 18:32:59 +0100, Trouilliez Vincent wrote:
   Version 1.4.0 required libgsf 1.10, but I had 1.9 on my system. I
   downloaded 1.10 from Gnumeric download page, installed it fine. Then I
   proceeded to removed the old 1.9 version and, can't believe it, my
   package manager (synaptic) removed half of my system !! it removbed
   Nautilus, many gnome bits, even Gimp, and hundreds of other packages !!
   What's te hell is going on ?!! :-OOOO

There are many packages that depend on "libgsf-1", either directly or
indirectly. The direct list ("apt-cache rdepends libgsf-1") includes
important packages like "gdm" and "librsvg2-2" (on which "nautilus" and
"gimp-svg" depend; "gimp" in turn depends on "gimp-svg").

   Now I don't want to reboot my system, it probably wouldn't start again
   with so many packages removed !! :-O

It probably will, though you may need to use console mode to get back to the
environment you're used to. Something like "apt-get install gnome-core" or
"apt-get install gnome-desktop-environment" will restore much of what you've

   How am I supposed to upgrade libgsf if removing the old version removes
   my entire desktop environement !!!!! :-O  :o(((((((((((((((

Wait for a packaged version. Binaries built against the older version of the
package still run against the newer version.

Mixing packages from a distribution with manually compiled binaries or
libraries is not something t
dit heerst      jennifer lopez op tv
geluid uit      en marilyn uit m'n speakers >:)                 
        <Typh> op #cistron

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]