Error in launching gnumeric

Hey !

When I'm launching gnumeric (0.61) I have this message :

Gnumeric failed to find a suitable default font. Please verify your gnome-print
installation. Your fontmap file could not be found in the expected location.

If you still have no luck, please file a proper bug report (see
http// including the following extra items :

1) The content of your fontmap file, if the file exist. (typically located in

2) The value of the LC_ALL environment variable LC_ALL=<N'a pas été défini>
3) The value of LANG environment variable LANG=fr_FR
4) What version of libxml gnumeric is running with. You may be able to use the
'ldd' command to get that information.

So I tried to run gnome-font-install. It made me a fontmap file but empty! With
with error message :

bash-2.04# ./gnome-font-install
** WARNING **: Warning: the Times font was not found. Printing is unlikely
to work unless basic fonts are installed. Please see:
for more information. 

I went to see at the URL and I found this :

Installing Type1 fonts for Gnome-Print 

Update: 6 Aug 2001 The Gnome-Print font installation process is rather broken.
I'm not maintainer of the project any more. If the suggestions on this page
don't work, I
don't have a solution, sorry. I'd be happy to link to other resources, so let me
know if you find any. 

Raph Levien <raph acm org> 
7 Jul 1999 

     Note: the font installation process is proving to be a lot trickier than we
thought. A new Gnome-Print package, expected soon, should have some of these
     wrinkles worked out. 

     Installing fonts for Gnome-Print is a bit trickier than it should be. Most
applications that print require at least the basic fonts of Helvetica, Times,
and Courier to
     be installed. If the gnome-print install did not find these fonts, this
guide should help you install them. 

     First, make sure that you have the font files. You'll need either Adobe or
URW fonts containing the .pfb files (glyph shape data). Fortunately, URW fonts
     freely available, for example as urw-fonts.tar.gz from The
URW fonts are also available in the RedHat 6.0 RPM named urw-fonts. 

     Then, go to the gnome-print build directory (I'm assuming you built out of
cvs), and run this command: 

     ./gnome-font-install --system --scan --no-copy
--afm-path=/usr/local/share/fonts/afms --pfb-assignment=ghostscript,<path>

     where <path> is substituted with your actual path to the .pfb files, for
example /usr/share/ghostscript/fonts. Also, /usr/local/share should be your
     data directory (gnome-print should have already installed the relevant .afm
files in the fonts/afms subdir). 

     Try printing a test page with testprint. 

     Hopefully, these font installation problems will largely become moot when
we start providing font packages that include the GnomePrint installation magic
     inside them. 

I've downloaded the  'urw-fonts.tar.gz'  file but I don't know what to do with

Could somebody explain to me how I can solve this pb?

Thank you for answers.

À bientôt.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]