Re: [GnomeMeeting-list] Help!! - ALSA crashes my Gnomemeeting

Damien Sandras wrote:

After a bit of searching on google, it seems that it can also be due to
the "APIC" support in kernels.

RedHat supports APIC machines, such as an old PII machine I have. The only
way it can operate is with APIC support:

[jeffco sitka jeffco]$ cat /proc/interrupts

CPU0 CPU1 CPU2 CPU3 0: 6849281 6865595 7027444 6698755 IO-APIC-edge timer
 1:          2          1          0          1    IO-APIC-edge  keyboard
 2:          0          0          0          0          XT-PIC  cascade
12:          2         14          1          3    IO-APIC-edge  PS/2 Mouse
18:     323328     354881     332402     332397   IO-APIC-level  eth0
54:          0          0          0          0   IO-APIC-level  usb-uhci
56:          6          9          6          9   IO-APIC-level  ncr53c8xx
57:      34690      34508      34352      33533   IO-APIC-level  ncr53c8xx
58:          4          3          5          7   IO-APIC-level  53c7,8xx
NMI:          0          0          0          0
LOC:   27442345   27442344   27442344   27442344
ERR:          0
The machine is currently running RH 7.3 and I plan to upgrade
it to 8.0 soon.


Do you know if redhat provides kernels with APIC support?
If so, can you try the ALSA RC5 again (you should be able to back up
your current install: make uninstall, make install to reinstall it), but
boot linux with the 'append noapic' line in /etc/lilo.conf ?

Thanks :)

Le mer 06/11/2002 à 23:34, Damien Sandras a écrit :
Perhaps I should mail the ALSA developers mailing list.
Once it works, can you mail me privately in a day or two to confirm me
that it never crashes?


(Perhaps you could also mail the ALSA developers mailing list to report
them the bug, they will surely ask you things about your setup).

My opinion is that there is a bug in ALSA 0.9.0 RC5 and that it is
independant of Redhat. (Mandrake people are using the ALSA version
shipping with MDK 9, which is a bit older).

Thanks for your contribution!

Le mer 06/11/2002 à 23:26, Marc Williams a écrit :
Ok, here's the latest on the Alsa drivers.

Sine the only way to use the FreshRPMs was to use the latest, 0.9.0rc5,
because they're the only ones that matched my kernel, Damien asked if I
would compile an older version since that wouldn't be kernel version
specific.  Just for the heck of it, and to make sure it wasn't just the
packaging done by Freshrpms, I compiled the latest version, rc5. Likewise, the compiled version crashed my system shortly after a
connection was established.

So it was then on to rc3, the version that Damien asked me to compile
from the start.  Bingo.  It works without crashing.  So iguess that
would lead one to believe that there is a compatibility issue between RH
8, rc5, and Gnomemeeting.

So the summary answer for anyone running Red Hat 8 and who wants or
needs to use the Alsa driver - compile the older Alsa 0.9.0rc3.

Now to figure out a few weird things with my new audio...  But at least
it doesn't crash.

On Wed, 2002-11-06 at 10:30, Marc Williams wrote:
On Wed, 2002-11-06 at 10:27, Damien Sandras wrote:
You are not the only one to mention kernel crashes using GnomeMeeting
under Redhat 8.0.
System crashing means a driver bug. As me, and many other people who are
using ALSA have no problem, it would indicate a Redhat 8.00 bug.
Did you have system crashing when using GnomeMeeting before using ALSA?
No.  It worked great.

Did you compile ALSA yourself?
No.  Used freshRPMs.

I'm doing a bit of looking elsewhere also.  I'd rather not remove ALSA
until I give it a fair workout so I'm looking forward to fixing this....

Le mer 06/11/2002 à 17:18, Marc Williams a écrit :
Being the compulsive tinkerer that can't leave well enough alone, I
decided to install ALSA on my RH 8.0 system.  Why?  I have no idea other
than a lot of people say very positive things about ALSA.  I followed
the directions on the freshrpms and ALSA sites to install.  Set a few
things in alsamixer and voila!  Everything seemed to work.

Until I fired up Gnomemeeting.  A few seconds after connecting with
anyone (I've tried two different people) my system locks up tighter than
a (pick your metaphore). Mouse is frozen, no keyboard, yadda yadda. Requires a hard boot. Thank goodness for ext3, eh?

All my other apps that I've tried so far seem to work well.  At least
those that deliver audio.  I don't have any other apps that use the mic.

So even though I'm fairly certain that this is not a Gnomemeeting issue
since it seems that a lot of people use ALSA with Gnomemeeting, I
thought I'd ask here for help.  After all, people here are nice and
besides, I'm not subscribed to an ALSA list.  :)

Not sure what info is needed to track this down.  Here's my modules.conf
(I'm sure it will wrap horribly):

alias parport_lowlevel parport_pc
alias eth0 eepro100
# alias sound-slot-0 es1371
# post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L
/dev/null 2>&1 || :
# pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S
/dev/null 2>&1 || :
post-install snd-card-0 /usr/sbin/alsactl restore >/dev/null 2>&1 || :
pre-remove snd-card-0 /usr/sbin/alsactl store >/dev/null 2>&1 || :
alias char-major-81 bttv
# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-ens1371
# module options should go here
# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0
# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

I really appreciate any pointers you can give to get this thing fixed so
that I don't have to back out the ALSA stuff.  In case it's not obvious
from the modules.conf file, my card is an Ensoniq ES1371.  CPU is a AMD
k6-2 400.  I used the RPMs available on the freshrpms site.


GnomeMeeting-list mailing list
GnomeMeeting-list gnome org
_	Damien Sandras
(o-	GnomeMeeting:
//\	FOSDEM 2003:
	H.323 phone:  callto:// seconix com

GnomeMeeting-list mailing list
GnomeMeeting-list gnome org

GnomeMeeting-list mailing list
GnomeMeeting-list gnome org

GnomeMeeting-list mailing list
GnomeMeeting-list gnome org
(o-      SANDRAS Damien
//\ v_/_ Check Out Gnome Meeting !

GnomeMeeting-list mailing list
GnomeMeeting-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]