Re: How to make GNOME THeme working ?

On Thu, 2007-12-13 at 14:23 +0530, Baiju M wrote:
> Hi all,
>          I have followed instruction in the recent threads and setup a
> development sandbox.  (I have documented it here:
> Now I am trying to get the "GNOME THeme" working.
> But I am not getting the look and feel of GNOME site.
> Any pointers ?

To get Gnome look and feel you'd have to apply the @@main_view to the
object you are trying to view. So what you'd do is select from the Add
New dropdown and add a new page. From what I have I don't see any work
done on the actual site theme or anything like that. Also there would be
a lot of work that needs to be done to get the current Gnome site inline
with what is currently here. A team, a plan and goals would have to be
setup for that.

> Then, what is thie 'MainPage' product used for ?
> Is it a classic Zope 2 product ?

It is a classic Plone product what it does is allow you to create a
MainPage. There is a problem here in regards to a var sin_tool I haven't
looked at yet but I guess I'll get around to that sometime today.

> I just copied this to 'wgo.buildout/products' folder, then I got some
> import error
> related to some 'CMF*' package, later I installed CMF-2.0 .
> Again I got a 'libxml2' import error, then I installed libxml2's Python
> binding from here:

Earlier in the thread:

      * In the MainPage product CMFCorePermissions was deprecated it is
        now just
      * permissions.
      * 40 - from Products.CMFCore.CMFCorePermissions import
      * 40 + from Products.CMFCore.permissions import setDefaultRoles

I should make one big patch for all of the stuff I did; i'll do that
after this email.

> I installed "GNOME THeme" and all other products showed up in
> "Add/Remove Products".  But when I access site I am getting
> a site without any CSS.

This would have to be setup or the Gnome THeme I have isn't the one that
was worked on.

> Also there is one broken product with description like this:
>     * PloneSoftwareCenter
>       Error Type
>           exceptions.ImportError
>       Error Value
>           No module named migrate

Hrmm what version of PloneSoftwareCenter is that?

Attached are screenshots of what you should be seeing.

> Regards,
> Baiju M
> _______________________________________________
> gnome-web-list mailing list
> gnome-web-list gnome org

Attachment: products.png
Description: PNG image

Attachment: theme.png
Description: PNG image

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]