Re: great job on Gnome 3

Earlier I wrote:

Here's the rub:  I cannot run Gnome 3 on the desktop machine, but I can
run it on the laptop machine.

When I log in on the desktop machine, even with Gnome 3 chosen
explicitly at the login prompt, it logs me into Gnome Classic anyway.

I fixed that problem by doing this:

$ sudo apt-get install firmware-linux-nonfree

Then I restarted the machine. (I probably could've done a modprobe, but
restart is fine.).  Then I could successfully log in with Gnome 3.

Problem solved.

Here's how I found the answer.  First I looked at dmesg:

$ dmesg

I saw this:

  *ERROR* radeon kernel modesetting for R600 or later requires

That was certainly all the clue I needed to do the apt-get install.

However, digging further, I searched for that exact error message in
duckduckgo and found this:

That page confirmed what I suspected.  I have a Radeon HD 4200 card, and
installing firmware-linux-nonfree solved the problem.

I am happily running Gnome 3 as we speak.

-- Patrick

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]