Re: Nautilus does not open files with the correct app

[Was: Strange behavior from gnome apps recently]

On Thu, 2007-08-02 at 10:42 -0700, Mark Hull-Richter wrote:
> Update:
> I can print complex graphics jpegs from the image viewer, but not from
> the GIMP.  Instead of an image, I get text that starts with %!
> PS-Adobe-3.0 and then pages and pages of junk.
> My pdf file associations in nautilus (2.16.2) do some really interesting
> things as well.  In the directory where I keep straight PDFs (those
> which are not associated with a particular other purpose) they work fine
> - I can view and print them with the Acrobat Reader just fine.  But now,
> in another directory where I keep a backup of one of my web sites, the
> file association is with the Acrobat Viewer, but if I double-click on
> the file in nautilus, I get this error window:
> ---
> Cannot open BullG250.pdf
> The filename "BullG250.pdf" indicates that this file is of type "pdf
> document". The contents of the file indicate that the file is of type
> "text/plain". If you open this file, the file might present a security
> risk to your system.
> Do not open the file unless you created the file yourself, or received
> the file from a trusted source. To open the file, rename the file to the
> correct extension for "text/plain", then open the file normally.
> Alternatively, use the Open With menu to choose a specific application
> for the file. 
> ---
> BUT, if I just use the "open with" link and select the Acrobat Reader,
> it opens just fine.  The 'file' command shows these all to be PDF
> version 1.3 format files, whereas my other PDFs range from version 1.2
> to 1.5, and those also print just fine (I tested with one of the 1.3
> files, but I've printed them all from time to time).
This is still happening, only I have managed to narrow it down to
Nautilus itself.  It absolutely will not open any files with their
associated application EXCEPT OO documents - .doc, .rtf, .xls, etc. all
work fine.  Any other files, pdfs, jpgs, mpgs, tifs, all of them, do not
open from nautilus.  I can open them with the "Open With" option on a
right click, but the double click fails with the above noted message
every time.

There has to be an option or setting or something in one of the config
files that controls this, and I believe it is permissions-related
because if I run as root, everything works fine, just not as a normal




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]