Re: Compile problems libgtop

Rebecca Ore <> writes:

> > 
> > The only remaining possiblity beyond what I've mentioned above this is
> > the guile build.  I did that from the site tarball, but may not have
> > rebuilt it since changing to the most recent gettext.  Tried to download
> > it today but couldn't connect.  If that is likely to be the problem, I
> > can rebuild that and start over again from glib and see if the situation
> > improves.  If that's not likely to be the problem, what is going on?
> > 
>  I checked some earlier notes and the error messages for were
>  Macro 'AM_PATH_GLIB' not found in library

This is most likely some problem with your aclocal installation which doesn't
find the glib.m4 file (should be in the directory `aclocal --print-ac-dir'
gives you).

>  Macro 'AM_GNOME_GETTEXT' not found in library

This is due to a bug in the libgtop-0.99.0 tarball - there's a file missing
in it, should work with the new libgtop-0.99.1 tarball from my site:

Well, sometimes one single error with this aclocal stuff can make configure
fail on certain tests and it may fail to set GLIBTOP_LINUX_VERSION_CODE
correctly due to this - and that's what's causing your parse error.


> During that attempt, I tried running autoconf, automake, and autoheader,
> still with same results.
> But everything else built, including the other two libs.  I've had a
> gtop working with this .rpm kernel before building 0.99 (0.30), so that
> doesn't seem likely.
> -- 
> Rebecca Ore
> Creativity is playing with the rule sets
> -- 
>         FAQ: Frequently-Asked Questions at
>          To unsubscribe: mail with 
>                        "unsubscribe" as the Subject.

   Martin Baulig - Angewandte Mathematik - Universitaet Trier,

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]