Re: [Gimp-user] Recurring mouse problem in GIMP 2.8.22

On 2021-07-15 22:44, Cliff Pratt via gimp-user-list wrote:
Although you say this only happens in GIMP, I would expect to have seen
many more complaints in the community if it was a GIMP (only) problem. I
would not give up on looking outside GIMP for the issue. It may be a
conflict between GIMP and some other software, running at the same time as
GIMP. eg Assistive technology software. Can you try with everything else

Thanks for that suggestion. I did that, and with nothing else loaded GIMP worked okay with the mouse, which it has done before. So I began loading up applications one at a time. It worked okay with one application after another loaded, and then I loaded up WordPerfect X5, which I have to use constantly. Bang! the mouse problem manifested itself.

To some slight degree I can probably leave WordPerfect X5 off for a while as I work in GIMP, but I need to work with both at once a lot of the time.

Now I'll note that GIMP 2.8 and WordPerfect X5 had been working together just fine for years. I have been suspecting all along that some Windows 10 "update" had caused the problem. I think that I might have put WordPerfect X5 into some compatibility mode at some point after I'd had some crashes of that software, again after years of no problems. I am wondering it I should risk crashes by undoing compatibility mode for WordPerfect X5, if that's even possible, or if I should try some sort of compatibility fix for GIMP.

Again, thanks.

On Fri, Jul 16, 2021 at 10:44 AM Techno <techno6 glib com> wrote:

On 2021-06-05 12:47, Marco Ciampa via gimp-user-list wrote:
On Sat, Jun 05, 2021 at 11:45:53AM -0400, Rick Strong wrote:
It sounds like a mouse problem, not a GIMP problem.

-Make sure the mouse switch is on, -try changing your batteries, -clean
"eye" underneath if it is an optical mouse, -check your connection if
it is
not wireless, -check your dongle if it is wireless, -try a new mouse
pad or
another surface.

Clearly it's not a mouse problem if it affects only GIMP and not the
entire system. In that case I suggest you to reset (=delete) the user
config data of GIMP here:

Okay, I've gone there, and I saw a lot of sub-directories, almost all of
them are empty. Some do have something in them: the patterns I've added,
the plug-in I've added and the tool-options.

I've followed the directions given at the above link, restarted GIMP and
the mouse problem, which only happens with GIMP, is still there. It's
making use of the software very difficult. In most instances when I use
the mouse I end up highlighting the thing I want to do with the mouse
and then I hit the ENTER key and it happens. Unfortunately, some
operations just need the mouse to choose what you want to do.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]