Re: [Gimp-developer] Error Message on Gegl - Last Git Master

On Sun, 26 Mar 2017 14:00:28 -0300
Americo Gobbo <jag rabisco gmail com> wrote:

I have installed my dependencies directly on my gimp folder because I 
had different dependencies outdated on my distro.
So, to install Pango 1.38 or higher is necessary to install also the 
dependencies of this version?
I have tried install in my 'make' environment the pango-1.38.1, but 
without success and on my ./configure (final part) has these messages:

checking whether the c++ linker (/usr/bin/ld -m elf_x86_64) supports 
shared libraries... yes
checking dynamic linker characteristics... (cached) GNU/Linux
checking how to hardcode library paths into programs... immediate
configure: creating ./ creating libtool
checking for some Win32 platform... no
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for HARFBUZZ... no
checking for CoreText availability... no
checking for CAIRO... yes
checking which cairo font backends could be used... none
configure: Disabling cairo support
configure: error: *** Could not enable any backends.
*** Must have at least one backend to build Pango.
Can you help to resolve the steps to follow?

Looks like Pango can't find the cairo freetype backend, which is
strange because it's installed by the "libcairo2-dev" package on
Ubuntu.  If you're building cairo yourself, you might be missing some
dependencies required to build freetype support.

On 26-03-2017 13:16, Ell via gimp-developer-list wrote:
Actually, there was an interval where gegl:text would get built
without checking this dependency, so it's possible that this is a
leftover from an earlier build (although that would be weird if
this problem only started recently.)  You can manually remove
"" (and make sure that it's not getting reinstalled by a
GEGL "make install") if that's the case.  It shouldn't be a problem
for GIMP for now, but in the long run it's better to get it built.  
Ok, now is Ok!
After LGM I am thinking install a new release of my distro... the 
current, sure is becoming a bit outdated ;-)
To install the new release of Pango is not recommended on my 
ubuntu-gnome 14.04?

You can probably install a new Pango relase on 14.04 if you're
persistent enough, but a shiny new distro is always better :)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]