[gedit-list] external tools menu options missing

Hi. I'm having trouble with the external tools plugin.

A few days ago I tried adding my own custom commands using the "Manage
External Tools" dialog. They seemed to worked fine for that session,
but when I restarted gedit, not only the new commands where missing,
but also most of the default commands, so the External Tools menu only
shows "Remove trailing spaces" and "Run command", even though the
"Manage External Tools" dialog shows also "Build command" and "Open
terminal here", as well as my own commands.

I tried removing all plugins, removing my local configuration files
(./gnome2/gedit, ./gnome2/accel/gedit, ./gconf/apps/gedit-2) and even
reinstalling gedit, gedit-common and gedit-plugins, but the other
default commands are still missing. Running gedit from a console does
not show any messages.

Why are these menu options missing? It looks like gedit is reading
some configuration file that was not restored during the reinstall, is
there any place where gedit or the External Tools plugin saves these?
How can I recover the menu options and add new ones that persist?


PS: I'm running gedit 2.28.0 on ubuntu 9.10

Ernesto Posse

Applied Formal Methods Group - Software Technology Lab
School of Computing
Queen's University - Kingston, Ontario, Canada

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]