Re: [Evolution] Failing to connect to Office365 account with MFA

Hi Milan,

On Tue, 2021-08-31 at 10:53 +0200, Milan Crha via evolution-list wrote:
On Thu, 2021-08-26 at 19:20 +0200, Vincent Hennebert via evolution-list

that's new to me. When you click the above URL, you can see the error
description. It doesn't tell much, but it suggests a wrong data had
been passed to the server.

I would verify the OAuth2 settings are correct on the EWS account (you
mentioned you use a custom Application ID and Tenant ID). You should
use a correct Redirect URI, registered with the Application ID.

I tried with and without filling in the Endpoint host
( and Redirect URI
( in the
advanced settings, but that does not change anything.

I'd probably try to close all Evolution processes (with
`evolution --force-shutdown`), then run "seahorse" and search in the
"Login" (or "Default") "Passwords" keyring for:

   Evolution Data Source - Office365[you company com]

which contains the credentials. Delete that entry. Then run
`evolution --force-shutdown` again, in case any other process ran it
again. After it run Evolution. It'll start the authentication from

Unfortunately, the exact same error remains after doing that.

By the way, you mentioned you changed the password. Where did you do
that, please? I suppose in the Outlook Web Access (OWA) interface? I
think the password change requires login in the OWA, the evolution-
cannot do it.

I used an internal website provided by my organisation that
synchronises the new password over all the systems.

I don’t actually sign in to OWA, I’m redirected straight away to the
org’s SSO system, and then back to OWA. I tried explicitly signing out
of OWA and back in, to see if maybe anything would change on the
Exchange server that would make an authentication from Evolution
succeed, but I still get the same error.

I don’t know if that matters, but I cannot access my email when not in
the company’s VPN. OWA shows something like ‘You cannot access this
page right now’ and Evolution, when it was working before I changed my
password, used to fail the authentication. Everything would get back in
order when I would join the VPN again.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]