Re: [Evolution] Can't synchronize address book


I have the same problem (and also never was able to get mutlisync to
work).  I use rsync instead.   Here's what I do.

First,  I am not in gnome on either machine, and more specifically, make
sure that gconfd-2 and the evolution programs aren't running. 

I do this by running 

evolution --force-shutdown


gconftool-2 --shutdown 

on both machines (and waiting a bit after).

I then run (on HOST2 in my home directory)

rsync -aurv --rsh=/usr/bin/ssh  HOST1:.evolution/ .evolution/

rsync -aurv --rsh=/usr/bin/ssh  .evolution/ HOST1:.evolution/

You have to sync the .gconf/app/evolution/ directories too, and you do
this in the same way (i.e., replace .evolution/ by .gconf/app/evolution/
everywhere in the above two rsync commands).

When you're done, you end up with the newest files on either machine on
both machines.

Of course you should put all this into a script (for example, I've
created a custom one that syncs these and various project directories at
the same time).

A word of caution:  BACK UP BOTH .evolution DIRECTORIES BEFORE YOU TRY

Another word of caution:  BACK UP BOTH .evolution DIRECTORIES BEFORE YOU

Also, you can forget the --rsh argument if you don't care about security
(I wouldn't).

Finally, I've done this while gnome was running (usually when I'm not
paying attention, and not intentionally).  The evolution
--force-shutdown and gconftool-2 --shutdown seem to do what they're
supposed to do, and I've never noticed a mismatch between what
evolution-data-server and/or gconfd cache and what appears on the other
disk, BUT, you get no guarantee that some other application won't start
these up again while you're doing the sync.

Good Luck

On Fri, 2007-06-29 at 21:09 +0300, Antonis Christofides wrote:

I want to synchronize address book between work and home, through the
network.  I read that this can be accomplished with multisync.  I tried
with multisync, but couldn't get it to work.  (I can go to the details
about what I did, but it's probably totally wrong, because I was
guessing).  I couldn't find any documentation.  Could you point me to
some instructions on how to do it?

Another thing I tried was to bring addressbook.db from work into
the .evolution/addressbook/local/system/ directory at home.  However,
the address book was still empty after I did that.  Could you explain to
me why?

I'm using Ubuntu 7.04 with its packaged evolution, 2.10.1.

Evolution-list mailing list
Evolution-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]