[Evolution] Evolution Data Server and KNOPPIX 3.4 (05-04-2004)

Hello everyone,

I'm sorry if this has been answered before, but so far I haven't had any
luck finding a solution.

This is a fresh install of Knoppix running on the stock 2.4.26 kernel.
Evolution was installed by apt-get (the evolution-1.5 package and the
evolution-data-server package out of the experimental tree). I also
installed the entire gnome desktop in case there was a missing package
in knoppix (apt-get install gnome-desktop). 

When I start Evolution, the mail all works fantastic. But when I click
on the Address Book I get...

"We were unable to open this addressbook.  Please check that the path
exists and that you have permission to access it."

I get a similar error when trying to add an event to the calendar saying
there is no active calendar. When I run evolution from a terminal I get
the following:

asked to activate component_id

(evolution-1.5:2875): libebook-WARNING **: e_book_construct: Could not
obtain a                                            handle to the
Personal Addressbook Server with IID `OAFIID:GNOME_Evolution_DataS

So I figured all of this must be handled by the evolution-data-server.
With evolution running I run 'ps aux | grep evolution' and see several
instances of evolution-1.5 and the evolution-alarm-notify running but no
data server running. So I close down evolution and run the evolution
data server directly...

$ /usr/lib/evolution/evolution-data-server
evolution-data-server-Message: Starting server

Fatal error: Cannot allocate memory

Has anyone else run into this problem? 
/usr/sbin/bonobo-activation-sysconf --display-directories 

returns nothing but /usr/lib/bonobo/servers seems to have all of the
evolution .server files anyways. 


Brian Ellis

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]