Re: [Evolution] bug: broken headers, revisited (bug huntin season opened)

Assuming its bash, you need to do


as well, or


or simply (on the one command line)

CAMEL_VERBOSE_DEBUG=1 evolution-mail

You should get a log of all the imap traffic when you do this, so it
should be obvious when it works.


On Fri, 2003-01-31 at 08:57, guenther wrote:
debug( 1 );

As with my last reply, attaching a CAMEL_VERBOSE_DEBUG log will help.
We can see then what the server is sending us ...

Sorry, I don't get that. I tried:
% evolution-mail

on another console:
% rm -Rf evolution/mail/imap/*
% evolution

Then displayed the mail in question. But there seems nothing relevant.
All I got was a couple of warnings like that:

Bonobo-WARNING **: Serious exception on node_set '$invalid path to XML user interface element' of '0' to 

And finally some font infos:

set_prop path: /commands/Messages
(0.0022s) [list] -adobe-helvetica-*-*-normal-*-*-*-*-*-p-*-iso8859-15 --> 48
(0.0004s) [load] -adobe-helvetica-medium-r-normal-*-12-*-*-*-p-*-iso8859-15 --> 0x821da10
(0.0003s) [load] -adobe-helvetica-bold-r-normal-*-12-*-*-*-p-*-iso8859-15 --> 0x8231130
(0.0045s) [list] -adobe-courier-*-*-normal-*-*-*-*-*-m-*-iso8859-15 --> 48
(0.0003s) [load] -adobe-courier-medium-r-normal-*-12-*-*-*-m-*-iso8859-15 --> 0x82a3680

Anyone can give me a hint how to debug that?


char *t="\10pse\0r\0dtu\0  ghno\x4e\xc8\x79\xf4\xab\x51\x8a\x10\xf4\xf4\xc4";
main(){ char h,m=h=*t++,*x=t+2*h,c,i,l=*x,s=0; for (i=0;i<l;i++){ i%8? c<<=1:
(c=*++x); c&128 && (s+=h); if (!(h>>=1)||!t[s+h]){ putchar(t[s]);h=m;s=0; }}}

evolution maillist  -  evolution lists ximian com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]