Re: [Evolution] Re: [Evolution-hackers] CVS IMAP

I don't see a symlink as a symlink - I see a set of folders as if they
were all in the same place.  And this has always worked with DtMail from
CDE, which is what I'm now having to call up to solve this filing
problem, and worked fine with Evolution before 1.0.8, as I said before. 
The server in all cases has been Sun's SIMS 2.0, although now at P12, so
this could have changed something.  I don't know when they last patched

It's just occured to me though that DtMail is doing the filing as a
local filesystem thing, and so not using IMAP - I've just played with it
as got it to search the same directory structure using IMAP instead of
local files and sure enough it too doesn't see these links to
directories elsewhere.  So that is it.  I need to come up with a way of
doing this with local files in Evo, and it sounds like 1.1/1.2 will have
this ability.  I'll look into it.

Thanks for the pointers.


On Tue, 2002-09-03 at 18:23, Jeffrey Stedfast wrote:
On Tue, 2002-09-03 at 12:04, Mark R. Bowyer wrote:
On Tue, 2002-09-03 at 02:06, Not Zed wrote:

just committed a big imap patch to cvs evo.  <SNIP>

I was going to post to this list about this, and your email gives me a
good excuse to do it now.  ;O)

Around 1.0.8, a change was made to the way folders are seen by the IMAP
system, in that (a) soft links are no longer followed; 

Sounds like nothing to do with Evolution.


 While I keep all my mail folders in a directory in my
(network mounted) home, for backup and access reasons, I move "old"
folders into another directory fairly regularly, to keep my disk usage
reasonable - and to do this I made a soft link to a directory on a local
disk.  This used to work fine on Evo < 1.0.8, and I was able to see the
directory of "old" folders in the folder view, and open it to look at
old emails and drop the occasional new email that needed to go in one of
them easily.

Sounds like a IMAP server bug. Remember that IMAP is not a file-system,
and therefor Evolution knows nothing about whether a folder is really a
symlink or not. If the IMAP server says "nope, so subfolders" then
Evolution says "okay, there are no subfolders" - end of story.

Now I don't even see links, and if I create a directory and link all the
folders within it, then I see an empty folder, not one with more folders

why would you see links to begin with? IMAP does not have a concept of

  So to view or file emails in these "old" folders I now have to fire
up another email tool =O(  I'm running on Solaris BTW, but I don't think
that's relevant.  I've tried linking to folders on the same mount point
to ensure this isn't a problem with the IMAP server or the client and
NFS mounting.

NFS mounting on the server-side would not affect the client. what other
email tool are you running that can see symlinks on IMAP? or are you
running something like pine or mutt on the server? If that is what you
are doing, then obviously that is why they can see it and Evolution

Was this a design decision, or just a result of a recoding that isn't

Sounds like a result of your IMAP server being broken.


Jeffrey Stedfast
Evolution Hacker - Ximian, Inc.
fejj ximian com  -

--------My opinion - Not sane, intelligent or necessarily useful--------
o o                                        mailto:Moredhel earthling net
/v\ark R. Bowyer    Mark Bowyer Sun COM
`-'               ------------------------------------------------------
 \ / ASCII Ribbon Campaign        fingerprint = 7924 9E9E 7B91 225E B065  
  X  Against HTML Mail         1024D/19BC72F6   39D0 551D ABE6 1514 0DC1
 / \ 

Attachment: signature.asc
Description: This is a digitally signed message part

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]