Re: [Evolution] Re: [Evolution-hackers] CVS IMAP

if this is purely on the imap server (or u do all mail via said server)
then as jeff said, it is most likely a server issue.

if some mail is accessed via evolution through  local disk i/o (or nfs),
then softlinks are not and never were suppopted configuration.  w/ 1.2 u
can just point to any arbitrary folder tree anyway.

On Wed, 2002-09-04 at 01:34, Mark R. Bowyer wrote:
On Tue, 2002-09-03 at 02:06, Not Zed wrote:

just committed a big imap patch to cvs evo.  <SNIP>

I was going to post to this list about this, and your email gives me a
good excuse to do it now.  ;O)

Around 1.0.8, a change was made to the way folders are seen by the IMAP
system, in that (a) soft links are no longer followed; and (b) the
building of the "new folder" window suddenly sped up by about 100
times.  While I found (b) very nice indeed, since I'm regularly
Ctrl-Alt-E -ing to create a new folder to contain emails on new subjects
(specifically new calls - I do technical support), I found (a) a
complete pain.  While I keep all my mail folders in a directory in my
(network mounted) home, for backup and access reasons, I move "old"
folders into another directory fairly regularly, to keep my disk usage
reasonable - and to do this I made a soft link to a directory on a local
disk.  This used to work fine on Evo < 1.0.8, and I was able to see the
directory of "old" folders in the folder view, and open it to look at
old emails and drop the occasional new email that needed to go in one of
them easily.

Now I don't even see links, and if I create a directory and link all the
folders within it, then I see an empty folder, not one with more folders
in.  So to view or file emails in these "old" folders I now have to fire
up another email tool =O(  I'm running on Solaris BTW, but I don't think
that's relevant.  I've tried linking to folders on the same mount point
to ensure this isn't a problem with the IMAP server or the client and
NFS mounting.

Was this a design decision, or just a result of a recoding that isn't
intended?  And if the latter, can it/is it fixed?  I'm not using
1.1.99.x yet coz I can't get the spell-checker working with it, and I've
become addicted to it.  But this fix would be much more important to
me.  The last 1.1.99 build I tried, though, I couldn't really get *any*
of my folders seen... =O(

--------My opinion - Not sane, intelligent or necessarily useful--------
o o                                        mailto:Moredhel earthling net
/v\ark R. Bowyer    Mark Bowyer Sun COM
`-'               ------------------------------------------------------
 \ / ASCII Ribbon Campaign      fingerprint = 7924 9E9E 7B91 225E B065  
  X  Against HTML Mail               1024D/19BC72F6   39D0 551D ABE6 1514 0DC1
 / \ 

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]