[Fwd: Fwd: Re: [Evolution] Extremely long link times]

PeterW's libtool fix does speed up the compile time considerably, but
Pilot conduits will not be linked correctly with the patch.  What will
happen is that when you try to do something with the EAddress component
it will complain of an unresolved symbol.  The only way to fix this is
to compile without the libtool fix (which really stinks, because on my
Athlon 1.2G/512MB RAM it takes 1 1/2 hours).

Basically libtool 1.4 sucks rocks when it comes to dependencies.


--- NotZed <notzed ximian com> wrote:
From: NotZed <notzed ximian com>
Subject: Re: [Evolution] Extremely long link times
To: alfons proteus demon nl (Alfons Hoogervorst)
Date: Tue, 23 Oct 2001 17:46:53 -0400 (EDT)
CC: evolution ximian com

This is libtools fault mostly, but also
gnome-config's fault (because
of limitations which pushed the problem into libtool
i guess).

There's a patch around for libtool 1.4 which is
supposed to address it
a little (try the archives).

Most of the time is spend in a stupid shell script
which attempts to detect
link dependencies, which also blows out the link
line. ld thankfully doesn't
slow down that much (well at least gnu ld) because
of it.


When linking something this seems to stick out
like sore thumb: The link
command line has more than 10 times references to
libraries like libz,
libdl, libXext, libX11, libSM, etc. The list
really goes on and on and on.

So, could this contribute to the extremely long
link times I have? And,
where does the mega long link command line and
duplicate lib references
come from? 


Ecuación algebraico sin solución posible,
a menos de poseer profundos conocimientos
en matemática - Revueltas (Ocho Por Radio)

evolution maillist  -  evolution ximian com

evolution maillist  -  evolution ximian com

Do You Yahoo!?
Make a great connection at Yahoo! Personals.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]