Re: [Evolution] locale not supporting by C library

Robert Rouys wrote:

Nevertheless, still the main problem (only with Evolution) : Evolution
can't read accented letters. I can type and see these letters on the
screen, but when i received the message I got something like "Président"
(President with e acute = e with 'accent).

What should it have been?
Is it just a problem with one letter/accent or are there problems with
all accented letters?

I think we now have some code to translate between UTF8 and the appropriate
charset for the locale, so we may have a bug in there.


It's a problem with all accented letters. When I  type  a 
message in the compose window, I see perfect accented letters; but I
can't type the accented letters
that require two keys like "a" and the dead key ^ ; I had to use an
external editor and cpy/paste. Then I can see all perfect accented
I made some checks. I compose a message with many accented letters. I
send it to myself.
Here is this message. I don't known what you'll see !!

"En été, au mois d'août, la voix aigüe de l'héroïque pâtre en colère,
là où les hêtres de l'île brûlent. "

And here is what I received:

"En &#-23;t&#-31; au mois d'ao&#-20;t, la voix aig&#-32;e de
l'h&#-17;ro&#-11;que p&#-14;tre en col&#-27;re,
r&#-17;sonne l&#-17; o&#-13; les h&#-14;tres de l'&#-27;le

At the same time, I download all mail with fetchmail and the same
message is quite readable.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]