Re: [Ekiga-list] STUN server "" replies Blocked, external IP

On 04/04/15 15:23, mdbug wrote:

On 04/04/2015 12:15 AM, John Talbut wrote:
On 03/04/15 17:08, mdbug wrote:

On 04/03/2015 10:10 AM, John Talbut wrote:

I had checked and have rechecked my router and ports 3478 - 3479 are
allowed.  Also I can successfully ping and run traceroute to

I would suggest running a VOIP port check.
Change _registar to your sip provider in the attached script and see
what happens.

Do read third paragraph of header for needed applications.

Thanks for that suggestion.  I changed _registar to "" and
I have run the test with various results.  The first time I tried it
this morning all the LAN ports passed and all the WAN ports failed.

Which would suggest router was blocking.

Subsequently when I run the test I get one or more of the LAN ports
failing, but different ones each time.

That is odd. There is a "-w 3" argument which indicates netcat (nc)
should wait 3 seconds before timing out causing the error message.

you could change  -w 3 to  -w 5 to see if the port test start working.
If it runs more reliably, I have no idea why it takes more than three
seconds to get a connection established.

I have no clue as to how long ekiga waits before timing out.

There can be no DNS issues because script gets the ip addresses prior to
starting test. See for yourself, paste these in a terminal.

     _lan_ip=$(hostname --ip-address)
     _wan_ip=$(wget -qO -

     echo "lan ip $_lan_ip"
     echo "wan ip $_wan_ip"

Test does assume ipv4 addressing.

My /etc/hosts.(allow | deny) files have no entries, everything in them
is commented out.  I do not have iptables installed.  My router appears
to be set up in accordance with and has not
been changed since Ekiga was working for me.

The only other variable is your ISP could have updated your router's
firmware or router has been cracked and port forwarding is different.

The port tests are dead simple. nc uses source port _sport=38564, opens
LAN_ip_addy:destination_port and sends message.

At end of run, uses pkill to close all ports, then runs test again for
WAN ip address if there were no LAN failures.

I am not getting much further. I have tried -w 5, -w 7 and even -w 10 but I still get one or more ports failing, different each time. I notice that when the ports pass there is a time delay but the fails come up almost immediately.

My router is under my control (my ISP does not have access to it) and there is no sign of it being hacked (it has a decent password).

I have been having a go with stun and I have got:

~$ stun 0
STUN client version 0.96
running test number 0
Primary: Blocked or could not reach STUN server 
Return value is 0x00001c
~$ stun
STUN client version 0.96
Primary: Indepndent Mapping, Port Dependent Filter, preserves ports, no hairpin
Return value is 0x000017

In other words it seems to work with but not with

Is the problem with the ekiga stun server?

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]