Re: [Ekiga-list] Ekiga Compilation on Windows

         I downloaded regex from and then tried make which again gave the folowing errors :

[root EICPU1065 Desktop]# make
make: dpkg-architecture: Command not found
echo Checking prerequisites...
Checking prerequisites...
hash i586-mingw32msvc-gcc i586-mingw32msvc-g++ i586-mingw32msvc-ld i586-mingw32msvc-nm i586-mingw32msvc-ar i586-mingw32msvc-ranlib i586-mingw32msvc-dlltool i586-mingw32msvc-dllwrap i586-mingw32msvc-objdump i586-mingw32msvc-windres i586-mingw32msvc-as||(echo You need to install mingw32;exit 1)
/bin/sh: line 0: hash: i586-mingw32msvc-gcc: not found
/bin/sh: line 0: hash: i586-mingw32msvc-g++: not found
/bin/sh: line 0: hash: i586-mingw32msvc-ld: not found
/bin/sh: line 0: hash: i586-mingw32msvc-nm: not found
/bin/sh: line 0: hash: i586-mingw32msvc-ar: not found
/bin/sh: line 0: hash: i586-mingw32msvc-ranlib: not found
/bin/sh: line 0: hash: i586-mingw32msvc-dlltool: not found
/bin/sh: line 0: hash: i586-mingw32msvc-dllwrap: not found
/bin/sh: line 0: hash: i586-mingw32msvc-objdump: not found
/bin/sh: line 0: hash: i586-mingw32msvc-windres: not found
/bin/sh: line 0: hash: i586-mingw32msvc-as: not found
You need to install mingw32
make: *** [binaries] Error 1

Do I need to yum install mingw32* ?
Can anybody please suggest as to what exact changes are required in makefile to compile it on Fedora 11 ?

Thanks & Regards,
Sohil Shah

On 10/28/2009 04:21 PM, Michael Rickmann wrote:
Am Mittwoch, den 28.10.2009, 14:49 +0530 schrieb Sohil Shah:
        Even i agree that native Mingw compilation is bit difficult. I
took the makefile from ekiga wiki page and when I executed  
make update-sources
I got the below given errors. 

[root EICPU1065 Desktop]# make update-sources
make: dpkg-architecture: Command not found
That is Debian specific, you will have to change it later for the real

Updating on Wed Oct 28 14:43:04 IST 2009
echo "--- Getting libregex..."
--- Getting libregex...
mkdir -p /home/sohil/Desktop/src/regex
cd /home/sohil/Desktop/src/regex; \
    for i in regex.c regexec.c regex.h regex_internal.c
regex_internal.h regcomp.c alloca_.h alloca.c strcase.h localcharset.c
localcharset.h;do \
      wget -nv -T 60 -N --no-proxy*checkout*/gnulib/gnulib/lib/$i ;\
2009-10-28 14:43:05 ERROR 403: Webcat Access denied.*checkout*/gnulib/gnulib/lib/regexec.c:
2009-10-28 14:43:06 ERROR 403: Webcat Access denied.

Ups, first thing I thought was that they changed the server. I just
tried it myself and from here, the download of regex worked. If you have
still difficulties outcomment the update-sources lines for regex in the
Makefile, download the rest and unpack in the src
directory which was generated.

Email Scanned for Virus & Dangerous Content by :


Disclaimer: This e-mail message and all attachments transmitted with it are intended solely for the use of the addressee and may contain legally privileged and confidential information. If the reader of this message is not the intended recipient, or an employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution, copying, or other use of this message or its attachments is strictly prohibited. If you have received this message in error, please notify the sender immediately by replying to this message and please delete it from your computer. Any views expressed in this message are those of the individual sender unless otherwise stated.Company has taken enough precautions to prevent the spread of viruses. However the company accepts no liability for any damage caused by any virus transmitted by this email.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]