Re: 0-byte recordings

Hi Sebastian,

I've resolved this problem now. It was partly my problem but I think there's also a bug in gnome-dvb-setup

Firstly there was a second gnome-dvb-daemon running when I generated that previous log. Sorry about that.

Also I was able to install 0.29 from an Ubuntu PPA. However this still suffered from the problem.

I eventually discovered that it whilst it failed on most channels some were working. Now I had had to generate my own dvb frequency file[1] as the one in the dvb-apps package hasn't been updated since the switch-off of analogue in my area. I had thought I had gotten it right but there were some values that were incorrect. Eventually (by googling the actual frequency value!) I found this message ( and whilst it's almost the same as my home-grown version I used that from then on.

What I discovered that I could only record channels on one of the muxes. This lead me to compare the channels.conf file I'd generate (with dvb-apps scan) with the ./config/gnome-dvb-daemon/channels-DVB-T.conf. I discovered that when gnome-dvb-setup uses the frequency file to scan for channels, it finds them all but it always writes the frequency from the first mux to *all* channels. So for example  if I do this:

cut -d: -f2 ./config/gnome-dvb-daemon/channels-DVB-T.conf | sort -u

I only get one line, where I should have five (one for each of the muxes it found channels on). Since the format is the same I copied the channels.conf that I was using for mplayer and vlc, restarted the daemon and then it all worked.

Do you want me to raise a bug for the scanning/conf file problem?

Thanks for your help

[1]not sure if that's the correct term but for me it's the file /usr/share/dvb/dvb-t/uk-Crystalpalace which has a list of frequencies and other parameters for the transmitter.

On 26 May 2012 15:50, Sebastian Pölsterl <sebp k-d-w org> wrote:
Hi Paul,

is it possible that another gnome-dvb-daemon instance was already
running at that time? If that's the case, you should kill it first.

Disabling the EPG scanner is definitely a good a idea to reduce the
noise. After that try scheduling a recording and see what's happening.
If everything works, the file size of the recording should increase
continuously. If not, the log may give some hints.

Best regards,

Am 26.05.2012 14:53, schrieb Paul Mason:
> Sebastian,
> Thanks for replying.
> I tried running debug following that link. For gnome-dvb-daemon --debug
> I got the following error in the output:
> default      ERROR      EPGScanner.vala:243: Internal data flow error.
> gstbasesrc.c(2625): gst_base_src_loop ():
> /GstPipeline:pipeline0/GstDvbSrc:dvbsrc:
> streaming task paused, reason error (-5)
> Which appears to be about EPG scanning and the EPG info is actually
> there. So I tried running with
> --disable-epg-scanner --disable-mediaserver2
> but this didn't help.
> I also ran with the Gstreamer debug. This created a largish log the
> start of which was:
> 0:00:00.100943520  4923  0x9919460 ERROR             rtspserver
> rtsp-server.c:657:gst_rtsp_server_get_io_channel:<GstRTSPServer@0x99a1a60>
> failed to create socket: Address already in use
> 0:00:00.101512200  4923  0x9919460 ERROR             rtspserver
> rtsp-server.c:857:gst_rtsp_server_create_watch:<GstRTSPServer@0x99a1a60>
> failed to create IO channel
> 0:00:00.101551280  4923  0x9919460 ERROR             rtspserver
> rtsp-server.c:896:gst_rtsp_server_attach:<GstRTSPServer@0x99a1a60>
> failed to create watch
> 0:00:00.211336600  4923  0x9919460 INFO                  dvbsrc
> gstdvbsrc.c:466:gst_dvbsrc_init:<GstDvbSrc@0x99d60e0> gst_dvbsrc_init
> 0:00:00.212129800  4923  0x9919460 INFO                  dvbsrc
> gstdvbsrc.c:537:gst_dvbsrc_set_property:<test_dvbsrc> Set Property:
> 0:00:00.214180480  4923  0x9919460 INFO                  dvbsrc
> gstdvbsrc.c:734:gst_dvbsrc_open_frontend:<test_dvbsrc> Using frontend
> device: /dev/dvb/adapter1/frontend0
> 0:00:00.358864440  4923  0x9919460 INFO                  dvbsrc
> gstdvbsrc.c:812:gst_dvbsrc_open_frontend:<test_dvbsrc> DVB card: DiBcom
> 3000MC/P
> Later on there was also the EPG error from the dvb-daemon debug output.
> The rest of the messages were not marked as ERROR though they may have
> given some idea what's going on but there was nothing obvious to me.
> I tried looking for something that's using the rtsp-server port - which
> should be 8554 I believe.
> netstat -pa | grep 8554
> tcp        0      0 localhost:8554          *:*
> LISTEN      1949/gnome-dvb-daem
> Which if I understand correctly (not great at net stuff) means the
> daemon itself is listening on that port.
> As for upgrading, I would rather stay with the version from my distro if
> possible. However I did download the source for 0.29 and ran the
> configure but it looks like there's a lot of stuff I'd need to update to
> get it to build. I'm not sure I want to do that if I don't know it's
> definitely going to work.
> Thanks
> Paul
> On 26 May 2012 12:41, Sebastian Pölsterl <sebp k-d-w org
> <mailto:sebp k-d-w org>> wrote:
>     Hi Paul,
>     you should try debugging the problem by following the instructions at
>     Hopefully this will get you an idea what is going wrong.
>     Regarding live TV, newer versions of GStreamer have a regression that
>     causes live TV to not work [1]. Last bot not least I highly encourage
>     you to update to the latest version 0.2.9.
>     [1]:
>     --
>     Sebastian Pölsterl
>     Am 26.05.2012 13 <tel:26.05.2012%2013>:30, schrieb Paul Mason:
>     > Hi,
>     >
>     > I've just installed Linux Mint 13 on a machine with a Hauppauge Nova-T
>     > 500 DVB TV card. The machine itself was previously a Mythtv server and
>     > worked well for years but now I'm re-purposing it as a desktop. I'd
>     > still like to play and record TV programs from it occasionally and I'm
>     > trying to use gnome-dvb-daemon for this.
>     >
>     > I've set up the device itself and am able to scan the channels
>     > successfully. I can use the device with mplayer and vlc without any
>     > problems. However when I try to use gnome-dvb-control to schedule a
>     > recording, I can see the channels and the EPG, I can add a
>     schedule and
>     > at the correct time it creates a subdirectory under
>     > $HOME/Videos/Recordings/{CHANNEL}/{DATE-TIME} and it appears to be
>     > recording but there's just a 0-byte file:
>     >
>     >
>     > <
>     <>>
>     >     |paul@pmdesk ~/Videos/Recordings/ITV1/2012-5-26_11-26 $ ls -l
>     >     total 4
>     >     -rw-r--r-- 1 paul paul   0 May 26 11:26 001.mpeg
>     >     -rw-r--r-- 1 paul paul 228 May 26 11:32 info.rec|
>     >
>     >
>     > Similarly when I try to use totem with the gnome-dvb plugin to view TV
>     > it gives me an error "location not found".
>     >
>     > It looks like some sort of permissions issue but I have all the
>     > permissions I need when running vlc or mplayer.
>     >
>     > The version is 0.27-2.
>     >
>     > Any ideas?
>     >
>     > Thanks
>     >
>     > --
>     > Paul Mason
> --
> Paul Mason
> _______________________________________________
> dvb-daemon-list mailing list
> dvb-daemon-list gnome org

Paul Mason

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]