Re: 0-byte recordings


Thanks for replying.

I tried running debug following that link. For gnome-dvb-daemon --debug

I got the following error in the output:

default      ERROR      EPGScanner.vala:243: Internal data flow error. gstbasesrc.c(2625): gst_base_src_loop (): /GstPipeline:pipeline0/GstDvbSrc:dvbsrc:
streaming task paused, reason error (-5)

Which appears to be about EPG scanning and the EPG info is actually there. So I tried running with

--disable-epg-scanner --disable-mediaserver2

but this didn't help.

I also ran with the Gstreamer debug. This created a largish log the start of which was:

0:00:00.100943520  4923  0x9919460 ERROR             rtspserver rtsp-server.c:657:gst_rtsp_server_get_io_channel:<GstRTSPServer@0x99a1a60> failed to create socket: Address already in use
0:00:00.101512200  4923  0x9919460 ERROR             rtspserver rtsp-server.c:857:gst_rtsp_server_create_watch:<GstRTSPServer@0x99a1a60> failed to create IO channel
0:00:00.101551280  4923  0x9919460 ERROR             rtspserver rtsp-server.c:896:gst_rtsp_server_attach:<GstRTSPServer@0x99a1a60> failed to create watch
0:00:00.211336600  4923  0x9919460 INFO                  dvbsrc gstdvbsrc.c:466:gst_dvbsrc_init:<GstDvbSrc@0x99d60e0> gst_dvbsrc_init
0:00:00.212129800  4923  0x9919460 INFO                  dvbsrc gstdvbsrc.c:537:gst_dvbsrc_set_property:<test_dvbsrc> Set Property: ARG_DVBSRC_POLARITY
0:00:00.214180480  4923  0x9919460 INFO                  dvbsrc gstdvbsrc.c:734:gst_dvbsrc_open_frontend:<test_dvbsrc> Using frontend device: /dev/dvb/adapter1/frontend0
0:00:00.358864440  4923  0x9919460 INFO                  dvbsrc gstdvbsrc.c:812:gst_dvbsrc_open_frontend:<test_dvbsrc> DVB card: DiBcom 3000MC/P

Later on there was also the EPG error from the dvb-daemon debug output. The rest of the messages were not marked as ERROR though they may have given some idea what's going on but there was nothing obvious to me.

I tried looking for something that's using the rtsp-server port - which should be 8554 I believe.

netstat -pa | grep 8554
tcp        0      0 localhost:8554          *:*                     LISTEN      1949/gnome-dvb-daem

Which if I understand correctly (not great at net stuff) means the daemon itself is listening on that port.

As for upgrading, I would rather stay with the version from my distro if possible. However I did download the source for 0.29 and ran the configure but it looks like there's a lot of stuff I'd need to update to get it to build. I'm not sure I want to do that if I don't know it's definitely going to work.


On 26 May 2012 12:41, Sebastian Pölsterl <sebp k-d-w org> wrote:
Hi Paul,

you should try debugging the problem by following the instructions at
Hopefully this will get you an idea what is going wrong.

Regarding live TV, newer versions of GStreamer have a regression that
causes live TV to not work [1]. Last bot not least I highly encourage
you to update to the latest version 0.2.9.


Sebastian Pölsterl

Am 26.05.2012 13:30, schrieb Paul Mason:
> Hi,
> I've just installed Linux Mint 13 on a machine with a Hauppauge Nova-T
> 500 DVB TV card. The machine itself was previously a Mythtv server and
> worked well for years but now I'm re-purposing it as a desktop. I'd
> still like to play and record TV programs from it occasionally and I'm
> trying to use gnome-dvb-daemon for this.
> I've set up the device itself and am able to scan the channels
> successfully. I can use the device with mplayer and vlc without any
> problems. However when I try to use gnome-dvb-control to schedule a
> recording, I can see the channels and the EPG, I can add a schedule and
> at the correct time it creates a subdirectory under
> $HOME/Videos/Recordings/{CHANNEL}/{DATE-TIME} and it appears to be
> recording but there's just a 0-byte file:
> <>
>     |paul@pmdesk ~/Videos/Recordings/ITV1/2012-5-26_11-26 $ ls -l
>     total 4
>     -rw-r--r-- 1 paul paul   0 May 26 11:26 001.mpeg
>     -rw-r--r-- 1 paul paul 228 May 26 11:32 info.rec|
> Similarly when I try to use totem with the gnome-dvb plugin to view TV
> it gives me an error "location not found".
> It looks like some sort of permissions issue but I have all the
> permissions I need when running vlc or mplayer.
> The version is 0.27-2.
> Any ideas?
> Thanks
> --
> Paul Mason

Paul Mason

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]