Re: Dia freeze up

At 12.09.2012 00:46, Michael Ross wrote:
I never did find a temp file.  I may be looking in the wrong place.  Hints?

Paste the link as I gave it in the Explorer address line. If no file opens try to navigate to %TEMP% alone. IIRC the default setting on Windows is to hide the temporary directory. The file gets newly created with every launch of Dia, so it will only contain useful information if you get it directly after a freeze up.

On Tue, Sep 11, 2012 at 6:32 PM, Michael Ross<michael e ross gmail com>  wrote:
Hello Hans,

I may have spoken too soon about re install fixing it, but it is easy
so I will try again.

Also the anti-alias - do you mean the setting in View Defaults?  I
have that unchecked.

I don't understand "antialiased (cairo) rendering" if that is different.


On Tue, Sep 11, 2012 at 3:51 PM, Hans Breuer<hans breuer org>  wrote:
At 09.09.2012 16:32, Michael Ross wrote:


This happens often, and I don't know how to trouble shoot it to provide
better information.

Checking changes in your usage pattern could be a starting point (or maybe
you are seeing more freezes with Dia 0.97.2 than with Dia 0.97.1?)

Running 0.97.2 on Win7

There was a big dependency update with the last minor update of Dia with the
dia-installer. So you might trigger some bug comming with that update.

Just now I was placing an arc between to circle centers.  The 3rd pick is
to change the diameter, when tried to do this it got stuck and I have the
busy cursor.   I will have to kill the program to get it free, start
and loose my work.

I recently had a freeze in cairo related to arcs with invalid parameters.
Are you using the antialiased (cairo) rendering? If so the probabilty of
freezes might be reduced by switching to the non-antialiased.

This happens nearly every time I use Dia.   I have not kept good track of
what I am doing when this happens.  It may only be the arc, but it may be
other functions as well.

Maybe the log-file %TEMP%\dia--0.97.2.log contains more information.

Any ideas about how to stop it without killing Dia?  Any ideas on how to
tell what causes the problem?

Not that I thought it would help, but last time reinstallation seems to have
solved your problem (-:

-------- Hans "at" Breuer "dot" Org -----------
Tell me what you need, and I'll tell you how to
get along without it.                -- Dilbert
dia-list mailing list
dia-list gnome org
FAQ at
Main page at

Put this question to yourself: should I use everyone else to attain
happiness, or should I help others gain happiness?
Dalai Lama

To invent, you need a good imagination and a pile of junk.
Thomas A. Edison

A public-opinion poll is no substitute for thought.
Warren Buffet

Michael E. Ross
(919) 550-2430 Land
(919) 576-0824 Google Phone
(919) 631-1451 Cell
(919) 513-0418 Desk

michael e ross gmail com

-------- Hans "at" Breuer "dot" Org -----------
Tell me what you need, and I'll tell you how to
get along without it.                -- Dilbert

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]