Re: RFC: GSound, a GObject library for playing system sounds

On 14 Nov 2014, at 8:15 pm, Sébastien Wilmet <swilmet gnome org> wrote:

On Fri, Nov 14, 2014 at 05:47:52PM +0800, Tristan Brindle wrote:

With the name GSound I was worried that you reused the g_ namespace (for
GLib), but it's not the case, so it's fine.


To follow the GIO convention for async operations, the first function
should be renamed as play_full_async(). So that in the future if you
want to create a sync version, you can name it play_full().

Thanks for the feedback :-)

In this case the async call will always be preferred, so if I ever added a sync version then it would be


I think this is the style gdbus uses for example to emphasise that you *should* be using the async version, 
so I figured I’d copy it.

I can certainly rename the function though if there is a consensus that I’ve got it wrong :-)



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]