Re: Update GnuTLS minimum dependency to 2.12.0?

On 08/26/2011 12:07 PM, Frederic Peters wrote:
In order to complete the GIO TLS Database work [1] for smart cards
and other PKCS#11 databases (like gnome-keyring), it looks like I'll
need to update the GnuTLS dependency [2] to 2.12.0 or later.

Any objections to doing this? Are we too late in the release cycle?

It looks really new.

It's about 5 months old, and was released about the time of GNOME 3.0. Various point versions (bug fixes) have come out for the 2.12.x branch, but 2.12.0 (actually 2.11.x, but that's unstable) has the new API we need.

it's not
available in Fedora 15 nor in Ubuntu 11.10; do you have a patch for
jhbuild to build gnutls 2.12,

Here you go:

does it work, are other packages using
gnutls working with the new version?

Yes, the two packages that use gnutls in jhbuild are:

glib-networking and NetworkManager

Both versions build fine with gnutls 2.12.0.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]