Re: minimal required version of GTK for GNOME 2.18

Quoting Jani Monoses <jani monoses gmail com>:

> Elijah Newren wrote:
> > On 2/19/07, Jani Monoses <jani monoses gmail com> wrote:
> >> Hi,
> >>
> >> is there a minimum required GTK+2.0 version that modules in svn trunk
> >> should depend on? I could only find the external dependency list in the
> > 
> > Why would we want to force people to require a higher version of gtk+
> > than they need?  gtk+ promises backward compatibility so there's no
> I did not suggest enforcing a specific version, but was wondering if the
> diversity is intentional.
> There are surely some modules where the requirement is there because nobody
> got around to bump it.
> Restating the question somewhat: are there reasons for specifically checking
> for pre 2.6
> platforms? Having a requirement on 2.4 is ok if no >=2.6 APIs are used, but
> ifdefs for pre and post
> 2.6 or 2.4 gtk are ugly (ex: network-manager-applet, gnome-games)

There may be some modules that besides being part of the GNOME 2.18 release set,
may be used in distributions whose GTK+ versions are older than 2.10. If the
maintainers of those modules still consider important to support older GTK+
versions, and they take care of it, I don't see a problem.

Furthermore, if some application X doesn't build with GTK+ Y because it's using
a newer API, it'd be a duty of the people using GTK+ Y to report it. If modules
still require those older versions, I guess it's either because they build and
work, or simply because no one has really used them with such an older GTK+ version.

(Though some #ifdef cleaning from time to time wouldn't be bad)


Claudio Saavedra <csaavedra alumnos utalca cl>

Este correo fue enviado por

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]