Re: new modules consensus

On Thu, 12 Aug 2004 18:37:20 +0100, Martyn Russell wrote:
>> Its not really this, Evolution requires a lot of testing and we like to
>> have snapshot available on a variety of platforms and until FC2 no one
>> included gtk+ 2.4 (well, maybe debian i guess).  We are moving away from
>> this need by going to shorter release cycles hence fewer features and
>> less testing required between releases.
> I would have thought given the recent versions of other libraries that
> you require for Evo 1.5 (libgnomeprint, gal, e-d-s, gtkhtml, to name a
> few), that GTK 2.4 wouldn't have been a problem.  But then, it is the
> bread and butter of Gnome (as I like to think of it) and perhaps thats
> why.
> Evolution 1.5 still rocks without it! :D

Ultra-new dependencies always hurt users by restricting the userbase that
can access this app.

For many people either:

- GTK 2.4 is not packaged for their distro


- They do not know how to install it from source

There is another issue here: upgrading GTK to 2.4 means upgrading GObject
and that breaks older versions of Gnome. So it's basically not possible
for most users to upgrade GTK without upgrading their distribution, which
I think isn't a requirement the Evolution team want to put on their users
and testers.

thanks -mike

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]