Re: gmime-sharp (was re: dos executables excluded from index?)


On Thu, 2006-09-28 at 10:24 +0200, Andreas Heinz wrote:
> i tried to change the line in to 2.1.19 but when i now 
> build beagle and run it, it always gives out the following lines:
> "** (/usr/local/lib/beagle/BeagleDaemon.exe:20785): WARNING **: The 
> following assembly referenced from 
> /usr/local/lib/beagle/BeagleDaemonLib.dll could not be loaded:
>       Assembly:   gmime-sharp    (assemblyref_index=6)
>       Version:
>       Public Key: 677013d4cb5910f0

This means that Beagle is still built against 2.2.x, which it can't

> i already tried to remove libgmime2.1-cil with "apt-get remove 
> libgmime2.1-cil" and then reinstalling it to make sure beagle won't use 
> some gmime-sharp 2.2 files anymore, but this didnt help

Unless the versioning is weird, this won't help: you're removing the
2.1.x package you need.  It's 2.2.x that you don't want (but apparently
have, because Beagle is built against it).

> is changing really the only thing i have to change in order 
> to get beagle 0.2.10 work with gmime sharp 2.1.19?

You have to change it, rerun (if from CVS) or autoreconf  and
configure (from tarball), make clean, make, make install.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]