Re: This is not a CVS folder

On Thu, 2006-06-22 at 10:32 +0200, Alessandro Magni wrote:
> kevin kubasik net wrote:
> > hey, a good option might be to try re-installing konqeror, as that
> > will traditionaly re-associate the mimetype of folders with konqeror.
> >
> > On 6/1/06, Alessandro Magni <magni inrim it> wrote:
> >> >
> >> > Anyway, using Nautilus, right click on a folder, and click Properties.
> >> > Go to the "Open With" tab and select the one you want.  That should be
> >> > it!
> >> thank you Joe,
> >> I clearly realize that Beagle is a Gnome project, and therefore I'm not
> >> assuming that everybody should stop what he/she is doing to make it
> >> fully KDE-compliant... anyway I really appreciate any bit of help!
> >> The message was clearly misleading ("If you did not intend to use
> >> Cervisia you can switch modes within Konqueror"): in Konqueror I did not
> >> find anything, while instead launching Nautilus as you suggested I
> >> observed that Right-clicking on a folder I get Permissions->Open with:
> >> just 2 choices, and the first one is Cervisia! The other one is simply
> >> "Open folder", but is uncheckable. I also tried the "Add" button to
> >> insert Konqueror from the list, but despite the fact that it does not
> >> give error messages, The "Open with" window remains unchanged:
> >> 1)Cervisia 2)Open with.
> I tried everything without success: folders always open with Cervisia, 
> and in no way Nautilus allows me to change that.
> So I did this dirty hack (very dirty indeed!): never using cervisia, I 
> mv'd-it, and in its place I put this 2-liner in perl, which I called 
> cervisia:
> #!/usr/bin/perl -w
> `konsole --notabbar --nomenubar -e mc $ARGV[0]`
> BUT - although it works when I call it directly: $> cervisia /tmp  => 
> opens a Konsole with mc pointing to /tmp, from beagle-search it doesnt 
> work this way.
> I checked, and saw that beagle-search outputs (when opening a folder) 
> this output:
> Cmd: cervisia
> Arg: -caption "%c" %i %m
> Itm: file:///0ale/ThinFilms/Fiber/Fe50Co50
> ScimInputContextPlugin()
> ~ScimInputContextPlugin()
> ... so the path is not on the command line! Then, how can I get from the 
> called command (my script) this Itm value?
> thanks for your help, people...
> alessandro

your technique works - i use a similar script to open movies in mplayer.
my question, though, is if you're sure that $ARGV[0] is the right one
for you. note how it says
> Arg: -caption "%c" %i %m
maybe the first argument is not the one you want. i would replace your
script with a bash script that prints all the arguments
echo $@
and then test it and see if it's calling it with just the path, or with
extra stuff. the argument you want may very well be another one. i hope
this helps you out. good luck!

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]