[Banshee-List] Curious Banshee freeze on startup

Hey All,

I've got an interesting problem with Banshee and I could use some
debugging tips...

Last night I was investigating some GUI issues and so I was in a tight
"change some code; make; make run; quit banshee" loop.  Sometimes it
was taking a long time to shut down, so I killed the process.  After
doing this 10-15 times, banshee stopped working.

When I run banshee now, a window pops up, but none of the widgets get
drawn and it pegs one of my processors at 100%.  It looks like it's
stuck in a loop doing something other than drawing stuff ;)  I let it
run overnight, thinking maybe it'd finish what it was doing, but it
never came back.

I reverted all of my code changes (I'm on trunk), rebuilt it, and did
a "make run" and I saw the same behavior.  I also see this behavior
when I run the latest banshee package installed with ubuntu's package
manager.  When I run it from the command line I don't see any strange
exceptions or anything else I'd consider strange in the output.

My first thought was that when I terminated the process I broke a
configuration file, so I rm -rf'ed ~/.config/banshee-1 and
~/.config/banshee, but that didn't resolve the issue. Then I tried
running banshee from a separate user account, and it worked perfectly.
 So I'm at a loss to explain this unless banshee stores per-user
config stuff someplace other than ~/.config.

 Any tips on how I can figure out where it's getting stuck?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]