Re: WebKitGTK+ in Balsa

Hi Peter:

Am 06.09.16 23:20 schrieb(en) Peter Bloomfield:
I just installed Trusty in a VM and will check if it compiles asap, stay tuned (until next weekend, I hope)...

Actually, libwebkitgtk-1 and libwebkitgtk-3 on Trusty (14.04 LTS) share the same api.  IOW, by tweaking the 
configure script to accept webkitgtk-3.0.pc for pkg-config as webkit (*not* webkit2), I could compile balsa.  
However, Trusty also supports libwebkitgtk-1, so a safe approach is just keeping everything as it is now.

Thinking again about the minimum requirements, I meanwhile doubt if we should actually be *that* strict 
regarding those older Debian-based systems.  I know several people running Debian oldstable /servers/ (where 
it makes sense, if the setup is complex, and server downtime is critical), but not desktops.  Likewise, I 
know a few very conservative users who upgrade their Ubuntu desktop to the latest LTS only 6-12 months after 
the release.

Thus, as we only focus on desktop users, the minimum requirements could be those for Debian stable (Jessie), and 
the /previous/ Ubuntu LTS (Trusty).  Basically, this would mean that glib >= 2.40 (instead of 2.32) and gtk 
>= 3.10 (instead of 3.4) is required.  It might be helpful if some of the newer functions could be used.

What do you think?

That would be helpful. We have some version-checks for gtk 3.8 and 3.10, and glib 2.35, so those could be 
cleaned up. Also, if the functions that are problematic in the 3.4 build are available in 3.10, that issue 
would go away :-)

The simple fact that nobody complained about compile errors on Wheezy or Ubuntu 12.04 LTS is a clear indication for 
me that we actually *can* move to glib >= 2.40 and gtk >= 3.10.

As I already mentioned, Debian/Ubuntu still come with old Balsa 2.4 versions.  Maybe we should sort out some 
pending issues, and then release version 2.5.3 - 2.5.2 is now more than 15 months (!) old, and in the 
meantime many improvements have been added IMO.

Things which might be candidates for fixes before release:
- weeding out deprecated stuff when we move to glib >= 2.40 and gtk >= 3.10 (easy)
- the spacing issue reported by Helmut 
(<>) - no idea how complicated it is
- the GtkHtml4 issue Jack reported (<>)
- Readme and Install instructions
- I would welcome if my POP3 auth issue 
(<>) gets fixed, as I want to move 
away from fetchmail, so I can encrypt my home folder... ;-)
- anything else?  I would still appreciate a consistent coding style, but that can definitely wait until 
after a new release!

What do you think?


Attachment: pgpJntSiTAH83.pgp
Description: PGP signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]