Re: WebKitGTK+ in Balsa

Hi Albrecht:

On 09/06/2016 03:57:51 PM Tue, Albrecht Dreß wrote:
Hi Peter:

Am 05.09.16 00:48 schrieb(en) Peter Bloomfield:
I don't know the difference between libwebkit2gtk-3.0 and libwebkit2gtk-4.0; the webkit2 API was unstable 
during development, so perhaps libwebkit2gtk-3.0 signifies an unstable version. I don't recall whether Balsa 
depended on any part of the API that changed during development; if not, it would probably build against the 
libwebkit2gtk-3.0 package, but I can't test that. Perhaps someone could test the current Balsa gtk3 branch in 
Ubuntu trusty.

I just installed Trusty in a VM and will check if it compiles asap, stay tuned (until next weekend, I hope)...

In a separate test, I already installed Debian Wheezy in a VM - and Balsa does *not* compile as gtk functions 
which are not available in 3.4.0 (our minimum requirement) are used.

Sigh--I try to keep those ifdef'd out! Where does the build fail?

Thinking again about the minimum requirements, I meanwhile doubt if we should actually be *that* strict 
regarding those older Debian-based systems.  I know several people running Debian oldstable /servers/ (where 
it makes sense, if the setup is complex, and server downtime is critical), but not desktops.  Likewise, I 
know a few very conservative users who upgrade their Ubuntu desktop to the latest LTS only 6-12 months after 
the release.

Thus, as we only focus on desktop users, the minimum requirements could be those for Debian stable (Jessie), and 
the /previous/ Ubuntu LTS (Trusty).  Basically, this would mean that glib >= 2.40 (instead of 2.32) and gtk 
>= 3.10 (instead of 3.4) is required.  It might be helpful if some of the newer functions could be used.

What do you think?

That would be helpful. We have some version-checks for gtk 3.8 and 3.10, and glib 2.35, so those could be 
cleaned up. Also, if the functions that are problematic in the 3.4 build are available in 3.10, that issue 
would go away :-)

Maybe we could dump a warning from configure when webkit is selected,

Yes, that seems like the least we could do...

I like your patch ()... :-)  Just a little nitpicking: configure --help still says

                          select the HTML renderer (default webkit)

Ouch! Will fix...

Thanks for all the feedback!


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]