Re: gpg related crash/hang on 2.0.11

On 2003.05.13 00:15, Carlos Morgado wrote:
> On Mon, 12 May 2003 23:05:22, Nuno Monteiro wrote:
>> nuno@hobbes:~$ gpg --keyserver --search-keys 
>> 0x1791665F
>> gpg: searching for "0x1791665F" from HKP server
>> Keys 1-1 of 1 for "0x1791665F"
>> (1)     Stephen P. Berry <>
>>           1024 bit DSA key 1791665F, created 2000-01-09
>> Enter number(s), N)ext, or Q)uit > q
> you have gnupg automagically fetching keys ?

I tried both ways, with and without auto-key-retrieve in gpg.conf, the 
outcome is the same -- it still hangs. The hairy part is that I've now 
tested with over 120 signed mails, and I can only reproduce the hang 
with this particular one, so I'm guessing its broken in any way, and 
confusing Balsa. I've attached that mail to the first message in this 
thread, should anyone want to take a look at it.

>> That 'SIGPIPE' in the backtrace doesnt look good. The fishy part is 
>> that it only hangs with this particular email, but works flawlessly 
>> with a good dozen others. Also, there are no 'gpg' processes running 
>> after balsa is hung, so killall or pkill would not matter.
> sigpipe means gpgme tried to write to gnupg after it closed a pipe.
> i wonder if it gets confused by that question .. or your gpgme 
> version doesn't like your gnupg version ..

Well, gpg is stock from mandrake 9.1, gpgme was built from source. 
Tomorrow I'll try building gpg myself and see if this persists. Still, 
it bugs me that only this mail triggers that condition...

> (btw, don't i know you ? :))

Humm, I'm not really sure, but I suppose not. Then again, Portugal is 
such a small "village", everyone knows each other :)



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]