Re: Dependency problems

Em Dom, 27 Jan 2002 02:49:37 Keith escreveu:
> I'm a newbie at compiling programs, so please bear with me. I'm running 
> Debian Potato on an i86 box, using icewm-gnome (but don't like to use full 
> gnome-session with panel, etc. I just enable gmc on startup to get icons on 
> desktop.) I have Gnome 1.4 installed. I did download and compile libesmtp 
> successfully. When I tried to configure Balsa 1.2.4, I received this 
> message:

You're getting gnome1.4 from ximian right ?

> <----------------------------------------------
> loading cache ./config.cache
> checking for a BSD compatible install... /usr/bin/install -c
> checking whether build environment is sane... yes
> checking whether make sets ${MAKE}... yes
> checking for working aclocal... missing
> checking for working autoconf... missing
> checking for working automake... missing
> checking for working autoheader... missing
> checking for working makeinfo... found
> checking whether to enable maintainer-specific portions of Makefiles... no
> checking for gnome-config... no
> checking for file in /usr/local/lib... not found
> ---------------------------------------------->
hum. ops. this comes from gnome itself. maybe you're lacking the devel 
packages ?

> I don't know how to find out whether I have the programs and versions 
> listed in INSTALL file (yes, I know, cluesless newbie) other than, if the 
> Debian package is of the same name, checking dselect, or running <name> 
> --version if it's a program.

dpkg is your friend. sorry i don't remember the right parameters, but it's
in there somewhere :)
dselect should also be able to tell you what you have installed

> I also downloaded the precompiled Potato binary (Balsa_1.2.pre1-1) 
> available from the website, and tried to install that. Dpkg told me I
i think that package depends on a particular ximian snapshot that's
prolly not available anymore

> needed libgal8, libgnomeprint11, libgtkhtml13, and libpspell2 packages. 
> Only libgal8 was included in my sources.  Sources.list includes the 
> following:
the other 2 are depressingly old. you should be able to rebuild it from
source in your system though

> <----------------------------------------------------
> deb stable main contrib non-free
> deb stable main
> deb 
> . .
> ----------------------------------------------------->
> However, the last line doesn't work. When I go there by hand, I find 
> libpspell2, but the other two files (libgnomeprint11 and libgtkhtml13) 
> either aren't there or aren't recognizable by their package names. But I'm 
> left wondering why I need to get obscure, obsolete files to run Balsa 
> anyway?
well, because you're trying to install an obscure obsolete version of
balsa :)
unfortunatly hardware conspired against my debian box and i'm unable to
build debs now :\

i see randall gibson has a 1.2.3 build for woody, you can try that but
i think it won't work for you on potato even with uptodate ximian gnome.

you can try getting apt-get install task-ximian-gnome, make sure you have
all the needed devel stuff and build balsa from source. help jules ? :)

> Is part of my problem that I'm not running the full gnome session? Is that 
> necessary to run--or compile--Balsa?
no, you need a somewhat complete gnome install to run/build but you
don't need to run a gnome session. you could just run balsa on bare X 

Carlos Morgado - chbm(at)chbm(dot)nu - -- gpgkey: 0x1FC57F0A FP:0A27 35D3 C448 3641 0573 6876 2A37 4BB2 1FC5 7F0A
[I could show you my .sig - but then I'd have to kill you]

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]