Re: [anjuta-devel] Rethinking the AnjutaProjectNode API

Hi Abderrahim,

Le 16/08/2011 15:05, Abderrahim Kitouni a écrit :
I'm not asking for a change in behavior, the correct behavior is fine
with me. Even if the source file is used by multiple targets, I could
work with whatever target I get.
What I was asking for is more cosmetic: changing the name of those
functions so they appear as methods of the node in the bindings.


This is the solution I was thinking about. Another idea (that could be
used in addition to this) is to use a hash table instead of a list to
ease lookups, or maybe not: it might be enough to just have a
lookup_property method.

I think we shouldn't have much properties so I don't think it's really useful to use a hash table.

Yeah. If we add a new id string, would your solution still be useful for
something (ans should be kept) or would it become completely useless?

My solution was to use additional members needed for something else. So even if I have an id string, they are still useful.

Then for the id string could you use a constant?
I mean that the id string is only the address of a constant. It even doesn't need to be a string and you check it with a pointer comparison.

Or do you need a real string?
I mean you have to check it using string comparison.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]