Re: [xslt] [Mingw-users] trouble building libxslt from xmlsoft

On 7/25/2012 10:47 PM, Mark Mikofski wrote:
libxslt always looks for libiconv in /usr/lib instead of /mingw/lib

I am trying to build libxslt for win32 with mingw (gcc 4.7) and using the native mingw libraries for libxml2, zlib and iconv. I can download precomiled binaries fro xmlsoft, but libxslt from xmlsoft doesn't find libiconv.dll on $PATH (.:/usr/local/bin:/mingw/bin:/bin) maybe because in /mingw/bin it's named libiconv-2.dll and in /bin it's named msys-iconv-2.dll. So you can download their iconv, xml2, xmlsec, zlib, etc, - that's what I did as a workaround, and put it in /opt which I can add to $PATH. But I would rather just rebuild xslt. 

1. edit configure to add -f to RM since it throws an error, "can't delete libtoolT" on lines containing "RM $(ofile)T"
2. from msys shell ./configure --without-python --without-crypto
3. make
libtool: link: returns the error, "/usr/lib/ is not a valid archive"

I tried various ways of overriding the library 
--with-libxml-libs-prefix='-L/usr/lib -lxml2 -L/mingw/lib -liconv'
LIBXML_LIBS='-L/usr/lib -lxml2 -L/mingw/lib -liconv'
I also tried LDFLAGS, but no matter what it always looks for in /usr/bin.

I usually do in MSYS export CPPFLAGS="-I/usr/local/include" and export LDFLAGS="-L/usr/local/lib"

I tracked down the line in libtools that is the culprit, and it looks like it just ignores the -L/mingw/lib part so I must be entering the configure options incorrectly.

I also tried to autoconf and autoreconf, but there are no or files in the tarball.

I also tried using the win32 folder that xmlsoft provides, and running cscript configure.js in a windows cmd console, after adding the path to my mingw and msys binaries. I used mingw32-make instead of make. I had to edit configure.js to include the headers, but it crashed somewhere in the c code (sorry I abandoned this approach, so I didn't record the actual error). I also tried msvc, using vcvarsall.bat, but I didn't try that hard, I had issues with libraries, but again, sorry, I didn't record the actual errors. I saw another mail list post on gnome-xslt for the same thing though, so I think the developers are aware of issues with the .js script, but most of the windows bugs are marked as resolved, notourbug or notgnome, so I didn't think it was correct to file a bug, especially since the binaries are available.

Thanks for any help.

Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and 
threat landscape has changed and how IT managers can respond. Discussions 
will include endpoint security, mobile security and the latest in malware 

MinGW-users mailing list
MinGW-users lists sourceforge net

This list observes the Etiquette found at
We ask that you be polite and do the same.  Disregard for the list etiquette may cause your account to be moderated.

You may change your MinGW Account Options or unsubscribe at:
Also: mailto:mingw-users-request lists sourceforge net?subject=unsubscribe

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]