RE: [xslt] xlstproc from Ant - can't create directories using -o?

The patch works fine if I run xsltproc on a file-by-file basis but I'm still
having problems when I invoke it from an Ant apply task.  This is Cygwin on
Windows so its a pretty arcane situation, but it may be an easy fix.  There
are plenty of layers here, so I don't know whether its ant, bash, cygwin or
java that's responsible for passing path separators in windows backslash
format.  Regardless, it happens and because Ant doesn't offer me the option
of swapping inside the apply task I cross my fingers and hope that xsltproc
can handle the format.

    [apply] Executing 'xsltproc' with arguments:
    [apply] '--version'
    [apply] '--xinclude'
    [apply] '--verbose'
    [apply] '-o'
    [apply] 'translations\category1\instance1.xml'
    [apply] 'stylesheets\stylesheet1.xsl'
    [apply] 'templates\category1\instance1.xml'

The good new is that it does just fine with the xml template and stylesheet:

    [apply] Initializing keys on templates/category1/instance1.xml
    [apply] Registering global variables from stylesheets/stylesheet1.xsl

but fails when attempting to obtain a url for the output file:

    [apply] xsltDocumentElem: URL parsing failed for

I've tried hard coding the -o parameter with forward slashes and the script
work fine  ... the downside is that all my output ends up in the same
location instead of neatly mirroring the input directory structure.  Given
that xsltproc handles backslash formatting for the input and stylesheet, I'm
hoping its an easy and obvious fix to have it do the same for output files.

Thanks again,


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]