[xml] libxml2 messed up MonoTouch and Interface Builder

I tried to install libxml2 yesterday for a Ruby side project of mine.
First I tried it with MacPorts but my MacPorts wouldn't work so I tried to download the source for libxml2 and "make" the install which ran with some errors but nothing that stopped the install.
That still didn't work for my Ruby coding (was trying to use the nokogiri library) so I got MacPorts working and installed libxml2 via that which eventually worked fine.

After that I went back to my MonoTouch iPhone development and noticed that MonoTouch would no longer work.
Now I don't actually get any error and am working with the MonoTouch people to figure that out, but if I try to use Interface Builder in OS X it errors when I try to create a new .xib file with this messageÂ(pastbin link).
The most important part of the message is this:
  1. Thread 0 Crashed: ÂDispatch queue: com.apple.main-thread
  2. 0  libxml2.2.dylib           0x00000001004f9b88 __xmlRaiseError + 888 (error.c:614)
  3. 1  libxml2.2.dylib           0x00000001004fa5b7 xmlErrEncodingInt + 151 (parserInternals.c:206)
  4. 2  libxml2.2.dylib           0x00000001004fc326 xmlCurrentChar + 550 (parserInternals.c:707)
  5. 3  libxml2.2.dylib           0x0000000100507168 xmlParseCharData + 904 (parser.c:4232)
  6. 4  libxml2.2.dylib           0x000000010051264e xmlParseTryOrFinish + 2014 (parser.c:10990)
  7. 5  libxml2.2.dylib           0x00000001005139bb xmlParseChunk + 411 (parser.c:11611)
  8. 6  com.apple.Foundation     Â   0x00007fff8759bca8 -[NSXMLParser parse] + 294
As you see, it errors on libxml2.
I REALLY need to figure out what is going on here. ÂMy knowledge in this area is not strong and I have no clue what is going wrong.
I have tried reinstalling libxml2 and MacPorts and have tried uninstalling libxml2 via MacPorts and no luck.

Please help.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]