Re: [xml] XML Schema crash in W3C test suite

On Thu, Mar 13, 2008 at 09:13:11AM +0100, Stefan Behnel wrote:
Daniel Veillard wrote:
On Thu, Feb 28, 2008 at 06:06:49PM +0100, Stefan Behnel wrote:
Daniel Veillard wrote:
On Thu, Feb 28, 2008 at 10:35:20AM +0100, Stefan Behnel wrote:
For the following test, however, I get a crash:


Valgrind gives me this:

==15628== Invalid free() / delete / delete[]
==15628==    at 0x402237F: free (vg_replace_malloc.c:233)
==15628==    by 0x4187985: xmlSchemaFreeValue
==15628==    by 0x416A6CC: xmlSchemaFreeFacet (xmlschemas.c:3927)
==15628==    by 0x416A742: xmlSchemaFreeType (xmlschemas.c:3954)
==15628==    by 0x416A9A9: xmlSchemaComponentListFree
==15628==    by 0x416AAAA: xmlSchemaBucketFree (xmlschemas.c:3504)
==15628==    by 0x410D7E8: xmlHashFree (hash.c:307)
==15628==    by 0x416AC49: xmlSchemaFree (xmlschemas.c:4119)
==15628==    by 0x804F853: main (xmllint.c:3534)
==15628==  Address 0x4389800 is 0 bytes inside a block of size 4
==15628==    at 0x402237F: free (vg_replace_malloc.c:233)
==15628==    by 0x4174BF8: xmlSchemaValidateNotation

  Okidoc, found and fixed in SVN, it was just a lack of a strdup for a 
string used to populate a structure.
  Valgrind passes with the binary runsuite built in the tree, and exercizing
the older test suite, so I assume it's not too bad and rather an isolated case
(who uses NOTATIONs really ;-) ?)


Red Hat Virtualization group
Daniel Veillard      | virtualization library
veillard redhat com  | libxml GNOME XML XSLT toolkit | Rpmfind RPM search engine

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]