Re: [xml] Problems with xmlFree and linking in Mingw gcc 3.2

On Wed, Sep 17, 2003 at 11:33:04AM +0200, Uwe Sander wrote:

On Mittwoch, 17. September 2003 10:15, Daniel Veillard wrote:
  One possible solution could be to call xmlMemSetup(), see

Same crashes here on NT, and xmlMemSetup () does not help in any way. I have 
provided a stub routine which does some debug output and a call to free. My 
routine gets called, but the same crash after a few calls. Even if I remove 
the free(), the whole thing crashes after a few calls to xmlFree. Next I 
tried was changing the calling convention (tried both __cdecl and __stdcall), 
but this did not make any difference either.
Any hint?

 1/ Ask you compiler vendor for help
 2/ Try another compiler
 3/ Ask your platform vendor for help
 4/ Switch to a reasonable platform :-\

If you don't have the informations needed to debug, well you can't debug.
Libxml2 comes with full source, you can check if the problem is there.
If you don't have the same capability on other pieces of your environment
maybe it's time to question this instead of libxml2 !
xmlMalloc is a pointer to a function in libxml2. It is a public variable
when using thread support it's actually attached to the thread context.
The value is initialized with malloc() at compile time statically.
Try to compile without libxml2 thread support...this might help too.


Daniel Veillard      | Red Hat Network
veillard redhat com  | libxml GNOME XML XSLT toolkit | Rpmfind RPM search engine

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]