Re: [xml] Debugging EXSLT function extension.

On Wed, Jul 09, 2003 at 10:26:58PM +0800, William M. Brack wrote:

  I'm getting yet another bug report with this extension:
Is there anybody who understand how it is supposed to work who could
look it up and fix this ?


The test case submitted with this bug was completely impractical to
investigate, other than to note it was apparently demonstrating the
difference between having an exslt function on a main stylesheet, or
on an imported stylesheet.

Assuming that this was the major complaint, I composed some test
cases of my own, each with a few tens of lines, which demonstrated
that there was, indeed, a problem with imported stylesheets.  I then
went into the libexslt coding and found the trouble area, enhanced
it, and committed the changes to CVS.  All of my test cases now work
without problem, and it appears that the original test case now
behaves correctly (although I am not entirely certain of that, since
I don't really understand what the test is supposed to do).

Sorry for that; when I shortened the test case, the error didn't
show up anymore and since I didn't knew where to look, I figured
it was better to have a large test which at least shows the behavior
rather than no test at all :-)

I downloaded the copy from CVS, and now, it works. Thanks a lot!

Sowatec AG,       CH-8330 Pfäffikon (ZH)
Witzbergstr. 7,
Tel: +41-(0)1-952 55 55
Fax: +41-(0)1-952 55 66
Aaron "Optimizer" Digulla, digulla sowatec com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]