Re: [Vala] [Libgee][RFC] Making Map<K, V> a Collection<Map.Entry<K, V> - Was: Libgee's Roadmap proposal



2009/7/24 Didier "Ptitjes" <ptitjes free fr>:
Levi Bard wrote:
- Renaming Map.remove(K key) in Map.unset(K key)
- Renaming Map.contains(K key) in Map.has(K key)
- Make Map<K, V> inherit from Collection<Map.Entry<K, V>>

I like unset. "has" is not different enough from "contains" for my
liking - I can see it being a source of future confusion ("What's the
difference between contains and has?!").
How about something that's clearly map-related, the way "unset" is?
"maps"? "has_set"?
(For a point of reference, ruby uses "has_key?" and "has_value?".)

Then I would say *get, set, unset, reset, has_key and has_value*...


I'm not sure about has_key and has_value. They just don't feel right
to me. It may be because I'm used to .NET's
contains_key/contains_value, but it also seems inconsistent, when we
already use "contains" in collections.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]